1. コマンド一覧

このシナリオで重要なコマンド一覧は以下の通りです。

Router(config)# ip router ospf <proc_num>
Router(config-ospfv2-1)# router-id <id>
Router(config-ospfv2-1)# network <addr>/<mask> area <area_num>

Router(config)# ipv6 router ospf <proc_num>
Router(config-ospfv3-1)# router-id <id>
Router(config-ospfv3-1)# network <interface> area <area_num>

2. 仕様説明

2.1. OSPFv2 (IPv4 OSPF)

OSPFv2の最小限の設定は以下networkコマンドの一文のみです。

Router(config)# ip router ospf <proc_num>
Router(config-ospfv2-1)# network <addr>/<mask> area <area_num>

必要に応じて、以下コマンドでrouter-idを明示指定する事ができます。

Router(config)# ip router ospf <proc_num>
Router(config-ospfv2-1)# router-id <id>

2.2. OSPFv3 (IPv4 OSPF)

OSPFv3を設定するにはrouter-idを明示指定する必要があります。 Cisco機と異なり、IPv4設定に応じて自動的にrouter-idが採番される仕様ではございません。 router-idは、IPv6 OSPFであってもIPv4形式である32bitの文字列を指定する必要があります。

Router(config)# ipv6 router ospf <proc_num>
Router(config-ospfv3-1)# router-id <id>

networkコマンドで、OSPFを有効にするインターフェースを指定します。

Router(config)# ipv6 router ospf <proc_num>
Router(config-ospfv3-1)# network <interface> area <area_num>

3. 動作確認環境

以下の構成で動作確認を行います。 GNS3のCiscoルータと実機のNEC IX2215を組み合わせて動作確認を行います。 実機エミュレータの混在環境構築手順についてはGNS3 実ネットワークとの接続設定を参照ください。

 [R1:Cisco]
interface Ethernet0/0
 ip address 192.168.0.1 255.255.255.0
 ipv6 address 2001::1/64
 ipv6 address FE80::1 link-local
interface Loopback0
 ip address 10.1.1.1 255.255.255.255
 ipv6 address 2001:1::1/128
 ipv6 address FE80::1 link-local

 [R2:Cisco]
interface Ethernet0/0
 ip address 192.168.0.2 255.255.255.0
 ipv6 address 2001::2/64
 ipv6 address FE80::2 link-local
interface Loopback0
 ip address 10.2.2.2 255.255.255.255
 ipv6 address 2001:2::2/128
 ipv6 address FE80::2 link-local

 [R254:IX2215]
interface GigaEthernet1.0
  ip address 192.168.0.254/24
  ipv6 address 2001::254/64
  no shutdown

初期設定の全文は以下を参照下さい。

4. OSPFv2 OSPFv3

4.1. Cisco機 設定投入

Cisco機側にOSPFv2, OSPFv3の設定を投入します。

 [R1:Cisco3640]
router ospf 1
 router-id 10.1.1.1
 network 10.1.1.1 0.0.0.0 area 0
 network 192.168.0.1 0.0.0.0 area 0
!
interface Ethernet0/0
 ipv6 ospf 1 area 0
interface Loopback0
 ipv6 ospf 1 area 0

 [R2:Cisco3640]
router ospf 1
 router-id 10.2.2.2
 network 10.2.2.2 0.0.0.0 area 0
 network 192.168.0.2 0.0.0.0 area 0
!
interface Ethernet0/0
 ipv6 ospf 1 area 0
interface Loopback0
 ipv6 ospf 1 area 0

4.2. NEC機 OSPFv2 設定投入

NECルータに、IPv4ルーティングであるOSPFv2の設定を投入します。

 [R254:IX2215]
ip router ospf 1
  network 192.168.0.0/24 area 0

4.3. NEC機 OSPFv3 設定投入

NECルータに、IPv6ルーティングであるOSPFv3の設定を投入します。 router-idの明示指定が必要である事に注意して下さい。

 [R254:IX2215]
ipv6 router ospf 1
  router-id 192.168.0.254
  network GigaEthernet1.0 area 0

4.4. OSPF 設定確認

OSPF interfaceが有効になっている事を確認します。 "show ip ospf interface", "show ipv6 ospf interface"コマンドを使用して下さい。

 [R254:IX2215]
R254(config)# show ip ospf interface
Interface           IP address      Area       Type      Cost  State    Nbrs
GigaEthernet1.0     192.168.0.254   0          BROADCAST 1     DR OTHER 2/2
R254(config)#
R254(config)#
R254(config)# show ipv6 ospf interface
Interface           ID    InstID ProcID AreaID     State     Cost   Pri  Nbrs
GigaEthernet1.0     2     0      1      0          DR OTHER  1      1    2/2
R254(config)#

OSPF neighborを確立できている事を確認します。

 [R254:IX2215]
R254(config)# show ip ospf neighbor
Neighbor ID     Pri State      Age IP address      Uptime    Interface
10.1.1.1        1   FULL/DR    2   192.168.0.1     0:22:52   GigaEthernet1.0
10.2.2.2        1   FULL/BDR   1   192.168.0.2     0:22:51   GigaEthernet1.0
R254(config)#
R254(config)#
R254(config)# show ipv6 ospf neighbor
Neighbor ID     PID   Pri State      Age   Uptime    Interface
10.1.1.1        1     1   FULL/BDR   10    0:18:12   GigaEthernet1.0
10.2.2.2        1     1   FULL/DR    7     0:18:12   GigaEthernet1.0
R254(config)#

経路情報を交換できている事を確認します。

 [R254:IX2215]
R254(config)# show ip route ospf
IP Routing Table - 2 entries, 3 hidden, 2043 frees
Entries: 0 Connected, 0 Static, 0 RIP, 2 OSPF, 0 BGP
Codes: C - Connected, S - Static, R - RIP, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, B - BGP
       * - Candidate default, s - Summary
Timers: Age
O      10.1.1.1/32 [110/2] via 192.168.0.1, GigaEthernet1.0, 0:23:35
O      10.2.2.2/32 [110/2] via 192.168.0.2, GigaEthernet1.0, 0:23:35
R254(config)#
R254(config)#
R254(config)# show ipv6 route ospf
IPv6 Routing Table - 3 entries, unlimited
Codes: C - Connected, L - Local, S - Static
       R - RIPng, O - OSPF, IA - OSPF inter area
       E1 - OSPF external type 1, E2 - OSPF external type 2, B - BGP
       s - Summary
Timers: Uptime/Age
O      2001::/64 global [110/1]
         via ::, GigaEthernet1.0, 0:18:42/0:00:00
O      2001:1::1/128 global [110/1]
         via fe80::1, GigaEthernet1.0, 0:18:43/0:00:00
O      2001:2::2/128 global [110/1]
         via fe80::2, GigaEthernet1.0, 0:18:43/0:00:00
R254(config)#

疎通確認は、NEC IX static routing 設定と同様の方法で可能です。 確認結果については省略します。

5. Tips

5.1. IPv6 OSPF router id

Cisco機の場合はIPv6 OSPF router idはIPv4設定に基づいて自動的に設定されますが、 NEC IXシリーズの場合はIPv6 OSPF router idの明示的な設定が必要となります。 もし、router idが明示的に設定されていない場合は、"OSPFv3 process is disabled" と表示されます。

R254(config)# show ipv6 ospf process
OSPFv3 Process ID: 1
  Notice: OSPFv3 process is disabled.
          Router ID should be set by unique value except zero.
  Router ID: 0.0.0.0
  Autonomous system boundary capability: no
  Area border capability: no
  Number of Areas: 1

 <omitted>