Cisco IOS フレームリレー – Back To Back 接続 01

スポンサーリンク

Frame RelayにおけるBack to Back接続についてまとめます。Back to Backとはフレームリレースイッチを使わない接続方法です。このページではLMIを無効にした接続方法について説明します。

概要

Back to Backには以下2通りの接続方法があります。このページでは前者のno_keepaliveについて説明します。

  • LMIを無効にした接続方法 (no keepalive)
  • LMIを有効にした接続方法 (hybird method)

構成図

以下の環境で動作確認を行います。

        s0/0      s0/1    s0/0      s0/1
  +------+.1      .2+------+.2      .3+------+
  |  R1  +----------+  R2  +----------+  R3  |
  +------+          +------+          +------+
       192.168.12.0/24    192.168.23.0/24

 [R1]
ipv6 unicast-routing
!
interface Serial0/0
 ip address 192.168.12.1 255.255.255.0
 encapsulation frame-relay
 ipv6 address FEC0:12::1/64
 ipv6 address FE80::1 link-local
 no keepalive
!
interface Loopback0
 ip address 10.1.1.1 255.255.255.255
 ipv6 address FEC0:1::1/64

 [R2]
ipv6 unicast-routing
!
interface Serial0/0
 ip address 192.168.23.2 255.255.255.0
 encapsulation frame-relay
 ipv6 address FEC0:23::2/64
 ipv6 address FE80::2 link-local
!
interface Serial0/1
 ip address 192.168.12.2 255.255.255.0
 encapsulation frame-relay
 ipv6 address FEC0:12::2/64
 ipv6 address FE80::2 link-local
!
interface Loopback0
 ip address 10.2.2.2 255.255.255.255
 ipv6 address FEC0:2::2/64

 [R3]
ipv6 unicast-routing
!
interface Serial0/1
 ip address 192.168.23.3 255.255.255.0
 encapsulation frame-relay
 ipv6 address FEC0:23::3/64
 ipv6 address FE80::3 link-local
!
interface Loopback0
 ip address 10.3.3.3 255.255.255.255
 ipv6 address FEC0:3::3/64

設定全文は下記ファイルです。詳細設定は下記を参照ください。

R1
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
!
!
ipv6 unicast-routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 10.1.1.1 255.255.255.255
 ipv6 address FEC0:1::1/64
 ipv6 ospf network point-to-point
!
interface Serial0/0
 ip address 192.168.12.1 255.255.255.0
 encapsulation frame-relay
 ipv6 address FEC0:12::1/64
 ipv6 address FE80::1 link-local
 serial restart-delay 0
!
interface Serial0/1
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
ip http server
ip forward-protocol nd
!
!
!
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
 login
!
!
end
R2
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
!
!
ipv6 unicast-routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 10.2.2.2 255.255.255.255
 ipv6 address FEC0:2::2/64
 ipv6 ospf network point-to-point
!
interface Serial0/0
 ip address 192.168.23.2 255.255.255.0
 encapsulation frame-relay
 ipv6 address FEC0:23::2/64
 ipv6 address FE80::2 link-local
 serial restart-delay 0
!
interface Serial0/1
 ip address 192.168.12.2 255.255.255.0
 encapsulation frame-relay
 ipv6 address FEC0:12::2/64
 ipv6 address FE80::2 link-local
 serial restart-delay 0
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
ip http server
ip forward-protocol nd
!
!
!
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
 login
!
!
end
R3
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
!
!
ipv6 unicast-routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 10.3.3.3 255.255.255.255
 ipv6 address FEC0:3::3/64
 ipv6 ospf network point-to-point
!
interface Serial0/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/1
 ip address 192.168.23.3 255.255.255.0
 encapsulation frame-relay
 ipv6 address FEC0:23::3/64
 ipv6 address FE80::3 link-local
 serial restart-delay 0
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
ip http server
ip forward-protocol nd
!
!
!
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
 login
!
!
end

DLCIが対向で同一の場合

PVC確立

R1, R2間でPVCを確立します。ポイントとなる設定は”no keepalive”です。普通の接続方法の場合、両方のルータがDTEとなるためLMIフレームを交換しません。そのため、デフォルトの状態ではLMIのkeepaliveが機能しないためdown状態になってしまいます。LMIのkeepalive機能を無効化するため、”no keepalive”を投入して下さい。

 [R1]
interface Serial0/0
 no keepalive
 frame-relay map ipv6 FE80::1 100
 frame-relay map ipv6 FE80::2 100 broadcast
 frame-relay map ipv6 FEC0:12::2 100
 frame-relay map ip 192.168.12.1 100
 frame-relay map ip 192.168.12.2 100 broadcast

 [R2]
interface Serial0/1
 no keepalive
 frame-relay map ipv6 FE80::1 100 broadcast
 frame-relay map ipv6 FE80::2 100
 frame-relay map ipv6 FEC0:12::1 100
 frame-relay map ip 192.168.12.1 100 broadcast
 frame-relay map ip 192.168.12.2 100

疎通可能になった事を確認します。

 [R1]
R1#ping 192.168.12.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.12.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/32/100 ms
R1#
R1#
R1#ping FE80::2
Output Interface: Serial0/0
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FE80::2, timeout is 2 seconds:
Packet sent with a source address of FE80::1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/32/104 ms
R1#
R1#
R1#ping FEC0:12::2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FEC0:12::2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/31/120 ms
R1#

IGPとの併用

R1, R2間でOSPF neighborを確立します。この時、OSPFv3はlink local addressを用いて経路を交換する事に注意して下さい。つまり、前述のframe-relay map ipv6の設定時に、link local addressも含めて設定する必要があります。

 [R1]
interface Serial0/0
 ip ospf network broadcast
 ipv6 ospf network broadcast
 ipv6 ospf 1 area 0
!
interface Loopback0
 ipv6 ospf network point-to-point
 ipv6 ospf 1 area 0
!
router ospf 1
 network 0.0.0.0 255.255.255.255 area 0

 [R2]
interface Serial0/1
 ip ospf network broadcast
 ipv6 ospf network broadcast
 ipv6 ospf 1 area 0
!
interface Loopback0
 ipv6 ospf network point-to-point
 ipv6 ospf 1 area 0
!
router ospf 1
 network 0.0.0.0 255.255.255.255 area 0

neighborが確立された事を確認します。

 [R1]
R1#show ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
10.2.2.2          1   FULL/DR         00:00:37    192.168.12.2    Serial0/0
R1#
R1#
R1#show ipv6 ospf neighbor

Neighbor ID     Pri   State           Dead Time   Interface ID    Interface
10.2.2.2          1   FULL/DR         00:00:33    4               Serial0/0
R1#

DLCIが対向で異なる場合

PVC確立 1

R2, R3間でDLCI203, 302を用いてBack to Back接続を行います。このような対向間でDLCIが異なる場合は、PVCがstaticに確立できるかどうか注意を払う必要があります。frame-relay mapまたはframe-relay interface-dlciで定義したDLCIに対してstaticなPVCが確立されます。

PVCを確立する1つの方法として、interface-dlciを定義する方法があります。

 [R2]
interface Serial0/0
 no keepalive
 frame-relay map ipv6 FE80::2 203
 frame-relay map ipv6 FE80::3 203 broadcast
 frame-relay map ip 192.168.23.2 203
 frame-relay map ip 192.168.23.3 203 broadcast
 frame-relay map ipv6 EFC0:23::3 203
 frame-relay interface-dlci 302

 [R3]
interface Serial0/1
 no keepalive
 frame-relay map ipv6 FE80::2 302 broadcast
 frame-relay map ipv6 FE80::3 302
 frame-relay map ip 192.168.23.2 302 broadcast
 frame-relay map ip 192.168.23.3 302
 frame-relay map ipv6 FEC0:23::2 302
 frame-relay interface-dlci 203

疎通可能になった事を確認します。

 [R2]
R2#ping 192.168.23.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.23.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/41/176 ms
R2#
R2#
R2#ping FE80::3
Output Interface: Serial0/0
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FE80::3, timeout is 2 seconds:
Packet sent with a source address of FE80::2
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/26/84 ms
R2#

PVC確立 2

もう1つの方法は、frame-relay map 定義時に、DLCI203, 302を織り交ざる方法です。

 [R2]
interface Serial0/0
 no keepalive
 frame-relay map ipv6 FE80::2 302
 frame-relay map ipv6 FE80::3 203 broadcast
 frame-relay map ip 192.168.23.2 203
 frame-relay map ip 192.168.23.3 203 broadcast
 frame-relay map ipv6 EFC0:23::3 302

 [R3]
interface Serial0/1
 no keepalive
 frame-relay map ipv6 FE80::2 302 broadcast
 frame-relay map ipv6 FE80::3 203
 frame-relay map ip 192.168.23.2 302 broadcast
 frame-relay map ip 192.168.23.3 203
 frame-relay map ipv6 FEC0:23::2 302

IGPとの併用

R2, R3間でOSPF neighborを確立します。

 [R2]
interface Serial0/0
 ip ospf network broadcast
 ipv6 ospf network broadcast
 ipv6 ospf 1 area 0

 [R3]
interface Serial0/1
 ip ospf network broadcast
 ipv6 ospf network broadcast
 ipv6 ospf 1 area 0
!
interface Loopback0
 ipv6 ospf network point-to-point
 ipv6 ospf 1 area 0
!
router ospf 1
 network 0.0.0.0 255.255.255.255 area 0

neighborが確立された事を確認します。

 [R2]
R2#show ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
10.3.3.3          1   FULL/BDR        00:00:36    192.168.23.3    Serial0/0
10.1.1.1          1   FULL/BDR        00:00:32    192.168.12.1    Serial0/1
R2#
R2#
R2#show ipv6 ospf neighbor

Neighbor ID     Pri   State           Dead Time   Interface ID    Interface
10.3.3.3          1   FULL/DR         00:00:38    4               Serial0/0
10.1.1.1          1   FULL/BDR        00:00:31    3               Serial0/1
R2#
タイトルとURLをコピーしました