Panasonic MNO Auto MDI / MDI-Xの設定

スポンサーリンク

パナソニックMNOシリーズのデフォルト設定はAuto MDI / MDI-Xが無効になっています。ストレートケーブル、クロスケーブルを意識しないで結線する場合は、Auto MDI / MDI-Xを有効にしないとリンク状態が”Down”のままでつながりません。

コマンド一覧

このシナリオで重要なコマンド一覧は以下の通りです。

Switch(config)# interface <interface>
Switch(config-if)# mdix auto

仕様説明

Auto MDI / MDI-X 有効化 – CLI 設定

以下のコマンドで、Auto MDI / MDI-Xを有効にする事ができます。

Switch(config)# interface <interface>
Switch(config-if)# mdix auto

Auto MDI / MDI-X 有効化 – GUI 設定

このようなinterfaceに対する一括設定はGUIの方が便利です。MNOシリーズは”interface range”相当のコマンドがないためCLIでinterfaceの一括設定はできません。

“基本機能設定”, “基本ポート設定”の順で押下するとAuto MDI / MDI-X一括設定変更の画面に遷移できます。

Panasonic MNO Auto MDI MDIX設定画面

GUIは非同期処理になっているため、クリックした内容が必ずしも設定変更される保障はありません。以下のようにCLIと合わせて設定確認を行うと効率よく作業できるでしょう。

SW1# show run
Building Configuration...
Current Configuration:
! -- start of config file --
! -- Software Version : 2.0.0.85 --
!
enable
config
!
hostname SW1
console inactivity-timer 0
telnet-server inactivity-timer 60
ip http server
!
ip address 192.168.0.1 255.255.255.0
ip default-gateway 192.168.0.254
!
spanning-tree rst version rstp
!
interface FastEthernet0/1
mdix auto
!
interface FastEthernet0/2
mdix auto
More .....To stop press (n)

動作確認環境

以下の構成で動作確認を行います。

構成図

 [SW1:MNO]
hostname SW1
console inactivity-timer 60
telnet-server inactivity-timer 60
ip http server
!
ip address 192.168.0.1 255.255.255.0
ip default-gateway 192.168.0.254

 [SW2:MNO]
hostname SW2
console inactivity-timer 60
telnet-server inactivity-timer 60
ip http server
!
ip address 192.168.0.2 255.255.255.0
ip default-gateway 192.168.0.254

初期設定の全文は以下を参照下さい。

SW1 config
! -- start of config file --
! -- Software Version : 2.0.0.85 --
!
enable
config
!
hostname SW1
console inactivity-timer 0
telnet-server inactivity-timer 60
ip http server
!
ip address 192.168.0.1 255.255.255.0
ip default-gateway 192.168.0.254
!
spanning-tree rst version rstp
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/25
!
interface GigabitEthernet0/26
!
interface vlan1
member 1-26
exit
!
! -- end of configuration --
SW2 config
! -- start of config file --
! -- Software Version : 2.0.0.85 --
!
enable
config
!
hostname SW2
console inactivity-timer 0
telnet-server inactivity-timer 60
ip http server
!
ip address 192.168.0.2 255.255.255.0
ip default-gateway 192.168.0.254
!
spanning-tree rst version rstp
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/25
!
interface GigabitEthernet0/26
!
interface vlan1
member 1-26
exit
!
! -- end of configuration --

Auto MDI / MDI-X 有効化

設定前の状態確認

MNOシリーズは”show interface info”コマンドによってポートの状態を確認する事ができます。実機ではLEDランプが点灯しているのでFa0/1の通電は問題ないようですが、showコマンドの出力はFa0/1がDown状態になっています。これはAuto-MDI/MDI-Xが無効になっているポート同士をストレートケーブルで結線したためです。

 [SW1:MNO]
SW1# show interface info

 Port  Trunk      Type      Admin     Link       Mode      Flow Ctrl   Auto-MDI
 ----  -----  -----------  --------   ----   ------------  ---------   --------
   1    ---      100TX     Enabled    Down   Auto           Disabled   Disabled
   2    ---      100TX     Enabled    Down   Auto           Disabled   Disabled
   3    ---      100TX     Enabled    Down   Auto           Disabled   Disabled
   4    ---      100TX     Enabled    Down   Auto           Disabled   Disabled
   5    ---      100TX     Enabled    Down   Auto           Disabled   Disabled

 <omitted>

Auto MDI / MDI-X 有効化

以下のコマンドを入力し、Auto MDI / MDI-Xを有効にします。

 [SW1:MNO]
interface FastEthernet0/1
 mdix auto

設定後の動作確認

“show interface info”コマンドによってポートの状態を確認します。Fa0/1がUp状態となり、Auto-MDIがEnableと表示されている事が読み取れます。

 [SW1:MNO]
SW1# show interface info

 Port  Trunk      Type      Admin     Link       Mode      Flow Ctrl   Auto-MDI
 ----  -----  -----------  --------   ----   ------------  ---------   --------
   1    ---      100TX     Enabled    Up     Auto (100F)    Disabled   Enabled
   2    ---      100TX     Enabled    Down   Auto           Disabled   Disabled
   3    ---      100TX     Enabled    Down   Auto           Disabled   Disabled
   4    ---      100TX     Enabled    Down   Auto           Disabled   Disabled
   5    ---      100TX     Enabled    Down   Auto           Disabled   Disabled

 <omitted>

SW1, SW2間で疎通可能である事を確認します。

 [SW1:MNO]
SW1# ping 192.168.0.2

Type Ctrl-C to abort.

Reply Received From :   192.168.0.2, TimeTaken :  6.45 ms
Reply Received From :   192.168.0.2, TimeTaken :  6.09 ms
Reply Received From :   192.168.0.2, TimeTaken :  2.45 ms

--- 192.168.0.2 Ping Statistics ---
3 Packets Transmitted, 3 Packets Received, 0% Packets Loss

SW1#
タイトルとURLをコピーしました