Panasonic MNO NTP(SNTP)の設定

スポンサーリンク

パナソニックMNOシリーズはSNTPによる時刻同期機能を備えています。SNTPはNTPの簡易版で、NTPとほぼ同じように設定する事ができます。

コマンド一覧

このシナリオで重要なコマンド一覧は以下の通りです。

Switch(config)# sntp server <addr>
Switch(config)# sntp poll-interval <min>

仕様説明

SNTPとは

SNTP(Simple Network Time Protocol )とは簡易版のNTPです。時刻問い合わせにかかる通信時間を考慮に入れたり複雑な認証機構があったり、NTPは複雑な仕様を多数兼ね備えています。このような複雑な仕様を排除したのがSNTPです。SNTPはNTPの部分集合と思って間違えありません。

ローエンドの機器はNTPではなくSNTPをサポートしている事が多いです。SNTPは通常のNTPサーバと同じように設定して差支えございません

SNTPサーバ設定

“sntp server”コマンドでNTPサーバを指定する事ができます。また、poll-intervalがデフォルト1440分(1日)になっていますので、検証を行う時は1分のような短めの値に変更しておくと良いでしょう。

Switch(config)# sntp server <addr>
Switch(config)# sntp poll-interval <min>

ciscoやjuniperなどの国際的なネットワークメーカーは初期設定がUTCになっていますので、timezone設定が必要になってきます。しかし、パナソニックは日本メーカーなので、デフォルト設定が”JST+9″になっています。パナソニックMNOシリーズを日本国内で使う場合は、timezoneに関する明示的な設定は必要ありません。

使う事は滅多にないと思いますが、timezoneを設定するコマンドは以下の通りです。

Switch(config)# sntp timezone <num>

動作確認環境

以下の構成で動作確認を行います。Host100はNTPサーバです。今回はNTPサーバとしてGNS3上のcisco3640をNTPサーバとして予め構築します。

構成図

 [SW1:MNO]
hostname SW1
console inactivity-timer 0
telnet-server inactivity-timer 60
ip http server
!
ip address 192.168.0.1 255.255.255.0
ip default-gateway 192.168.0.254

 [Host100:Cisco3640]
ntp master 8
clock timezone JST +9
!
! "enable mode"で入力してください。
clock set 16:00:00 Feb 11 2014

初期設定の全文は以下を参照下さい。

SW1 config
! -- start of config file -- 
! -- Software Version : 2.0.0.85 -- 
!
enable
config
!
hostname SW1
console inactivity-timer 0
telnet-server inactivity-timer 60
ip http server
!
ip address 192.168.0.1 255.255.255.0
ip default-gateway 192.168.0.254
!
spanning-tree rst version rstp
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/25
!
interface GigabitEthernet0/26
!
interface vlan1
member 1-26
exit
!
! -- end of configuration --

SNTP 設定

設定前の動作確認

“show sntp”で現在時刻およびSNTP設定を確認する事ができます。初期状態では2001/01/02となっております。

 [SW1:MNO]
SW1# show sntp

 Time ( HH:MM:SS )     : 12:12:08
 Date ( YYYY/MM/DD )   : 2001/01/02     Tuesday

 SNTP Server IP        : 0.0.0.0
 SNTP Polling Interval : 1440 Min
 Time Zone             : (GMT+09:00) Osaka,Sapporo,Tokyo
 Daylight Saving       : N/A

SW1#

SNTPサーバの設定

MNOシリーズにSNTPサーバのIPアドレスを指定します。これで、Cisco3640がSNTPサーバで、MNOがSNTPクライアントの構成になりました。

 [SW1:MNO]
sntp server 192.168.0.100
sntp poll-interval 3

動作確認

SW1, Host100の間で時刻が大幅にずれていない事を確認します。

 [Host100:Cisco3640]
Host100#show clock
16:05:22.591 JST Tue Feb 11 2014
Host100#

 [SW1:MNO]
SW1# show sntp

 Time ( HH:MM:SS )     : 16:05:24
 Date ( YYYY/MM/DD )   : 2014/02/11     Tuesday

 SNTP Server IP        : 192.168.0.100
 SNTP Polling Interval : 3 Min
 Time Zone             : (GMT+09:00) Osaka,Sapporo,Tokyo
 Daylight Saving       : N/A

SW1#
タイトルとURLをコピーしました