Panasonic MNO PoEの設定

スポンサーリンク

パナソニックMNOシリーズの最大のセールスポイントはPoE(Power Over Ethernet)です。デフォルト設定でもPoEを使用する事ができますが、PoEの状態確認手法や高度な設定方法についてまとめます。

コマンド一覧

このシナリオで重要なコマンド一覧は以下の通りです。

Switch(config)# peth usage-threshold <percent>
Switch(config)# peth disconnection-method [ low-priority | next-port ]

Switch(config)# interface <interface>
Switch(config-if)# peth priority [ critical | high | low]
Switch(config-if)# peth limit <mW>
Switch(config-if)# peth shutdown

仕様説明

PoE 状態確認

IP電話などPoEが必要な環境を運用するとなると、現状の使用電力は非常に気がかりです。

“show peth-conf”コマンドや”show peth-port”コマンドで、電力総使用量や各ポートの電力使用量を調査する事ができます。

Switch# show peth-conf
 Power Budget :                           175W
 Power Consumption :                      39W
 Power Usage Threshold For Sending Trap:  50 %
 Power Management Method :  Deny next port connection, regardless of priority

Switch#
Switch#
Switch# show peth-port
 No. Admin  Status        Class Prio.  Limit(mW)  Pow.(mW)   Vol.(V)   Cur.(mA)
 --- ----- -------------- ----- ------ --------- --------- --------- ----------
  1   Up   Not Powered       0  Low       15400         0         0          0
  2   Up   Powered           0  Low       15400      2500        49         52
  3   Up   Powered           1  Low       15400      2100        50         42
  4   Up   Powered           1  Low       15400      2000        49         41
  5   Up   Powered           1  Low       15400      2100        49         43
  6   Up   Powered           1  Low       15400      2000        49         42
  7   Up   Powered           1  Low       15400      2100        50         43
  8   Up   Powered           1  Low       15400      2100        49         43
  9   Up   Powered           1  Low       15400      2000        50         41
 10   Up   Powered           1  Low       15400      2000        49         42
 11   Up   Powered           1  Low       15400      2000        50         41
 12   Up   Not Powered       0  Low       15400         0         0          0
 13   Up   Powered           1  Low       15400      2000        49         42
 14   Up   Powered           0  Low       15400      2300        49         48
 15   Up   Powered           1  Low       15400      2100        49         44
 16   Up   Powered           0  Low       15400      2300        49         48
 17   Up   Powered           1  Low       15400      2500        49         52
 18   Up   Not Powered       0  Low       15400         0         0          0
 19   Up   Powered           0  Low       15400      2500        49         51
 20   Up   Not Powered       0  Low       15400         0         0          0
 21   Up   Powered           0  Low       15400      2400        49         50
 22   Up   Not Powered       0  Low       15400         0         0          0
 23   Up   Not Powered       0  Low       15400         0         0          0
 24   Up   Powered           1  Low       15400      2100        49         44

Switch#

同様に、MenuモードやGUIモードでも電力総使用量や各ポートの電力使用量を調査する事ができます。

Panasonic MNO PoEのメニュー確認

Panasonic MNO PoEのブラウザ確認

トラップ 閾値

MNOシリーズは総電力使用量が上限の50%まで達した時にトラップで通知します。50%という閾値はかなり厳しめの値であると思いますので、閾値を変更しトラップを抑制したい場合は以下のコマンドを使用します。

Switch(config)# peth usage-threshold <percent>

電力の優先供給

デフォルトの動作は、電力供給が上限に達した場合、最も最近つながれたポートへの電力供給を止めます。しかし、時には”exectiveの電話だけは止めたくない”のようなニーズもあるかもしれません。そのような場合は、”peth disconnection-method low-priority”と入力する事で、優先度の低いポートの電力供給を止めるようになります。

Switch(config)# peth disconnection-method [ low-priority | next-port ]

以下のコマンドで電力供給の優先度を定義する事ができます。デフォルト設定はlowです。

Switch(config)# interface <interface>
Switch(config-if)# peth priority [ critical | high | low]

供給電力の上限

“peth limit”コマンドで供給する電力の上限を定義する事ができます。

Switch(config)# interface <interface>
Switch(config-if)# peth limit <mW>

また、”peth shutdown”コマンドを使用すると、電力を供給しないようにする事ができます。

Switch(config)# interface <interface>
Switch(config-if)# peth shutdown

動作確認環境

以下の構成で動作確認を行います。

構成図

 [SW1:MNO]
hostname SW1
console inactivity-timer 0
telnet-server inactivity-timer 60
ip http server
!
ip address 192.168.0.1 255.255.255.0
ip default-gateway 192.168.0.254

初期設定の全文は以下を参照下さい。

SW1 config
! -- start of config file -- 
! -- Software Version : 2.0.0.85 -- 
!
enable
config
!
hostname SW1
console inactivity-timer 0
telnet-server inactivity-timer 60
ip http server
!
ip address 192.168.0.1 255.255.255.0
ip default-gateway 192.168.0.254
!
spanning-tree rst version rstp
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/25
!
interface GigabitEthernet0/26
!
interface vlan1
member 1-26
exit
!
! -- end of configuration --

PoE 全体設定

設定投入

スイッチ全体に関わるPoE設定を行います。設定例は以下の通りです。

 [SW1:MNO]
peth usage-threshold 70
peth disconnection-method low-priority

設定確認

設定した内容が”show peth-conf”に出力されるかどうかを確認します。

 [SW1:MNO]
SW1# show peth-conf
 Power Budget :                           175W
 Power Consumption :                      1W
 Power Usage Threshold For Sending Trap:  70 %
 Power Management Method :  Low priority port will be shut down

SW1#

PoE ポートに関する設定

設定投入

ポート単位のPoE設定を行います。設定例は以下の通りです。

 [SW1:MNO]
interface FastEthernet0/1
 peth priority critical
!
interface FastEthernet0/2
 peth priority high
!
interface FastEthernet0/7
 peth limit 3000
!
interface FastEthernet0/8
 peth shutdown

設定確認

設定した内容が”show peth-port”に出力されるかどうかを確認します。

 [SW1:MNO]
SW1# show peth-port
 No. Admin  Status        Class Prio.  Limit(mW)  Pow.(mW)   Vol.(V)   Cur.(mA)
 --- ----- -------------- ----- ------ --------- --------- --------- ----------
  1   Up   Powered           1  Crit.     15400      1800        49         38
  2   Up   Not Powered       0  High      15400         0         0          0
  3   Up   Not Powered       0  Low       15400         0         0          0
  4   Up   Not Powered       0  Low       15400         0         0          0
  5   Up   Not Powered       0  Low       15400         0         0          0
  6   Up   Not Powered       0  Low       15400         0         0          0
  7   Up   Not Powered       0  Low        3000         0         0          0
  8  Down  Not Powered       0  Low       15400         0         0          0
  9   Up   Not Powered       0  Low       15400         0         0          0
 10   Up   Not Powered       0  Low       15400         0         0          0
 11   Up   Not Powered       0  Low       15400         0         0          0
 12   Up   Not Powered       0  Low       15400         0         0          0
 13   Up   Not Powered       0  Low       15400         0         0          0
 14   Up   Not Powered       0  Low       15400         0         0          0
 15   Up   Not Powered       0  Low       15400         0         0          0
 16   Up   Not Powered       0  Low       15400         0         0          0
 17   Up   Not Powered       0  Low       15400         0         0          0
 18   Up   Not Powered       0  Low       15400         0         0          0
 19   Up   Not Powered       0  Low       15400         0         0          0
 20   Up   Not Powered       0  Low       15400         0         0          0
 21   Up   Not Powered       0  Low       15400         0         0          0
 22   Up   Not Powered       0  Low       15400         0         0          0
 23   Up   Not Powered       0  Low       15400         0         0          0
 24   Up   Not Powered       0  Low       15400         0         0          0

SW1#
タイトルとURLをコピーしました