Panasonic MNO STP チューニング

スポンサーリンク

パナソニックMNOシリーズにおけるRSTPのチューニング設定例を紹介します。他のネットワーク機器同様に、Root Bridgeを設定したりCostを設定したりする事ができます。

コマンド一覧

このシナリオで重要なコマンド一覧は以下の通りです。

Switch(config)# spanning-tree mst priority lt;priority>

Switch(config)# interface <interface>
Switch(config-if)# spanning-tree rst cost <cost>
Switch(config-if)# spanning-tree rst port-priority <num>

Switch(config)# spanning-tree rst hello-time <sec>
Switch(config)# spanning-tree rst forward-time <sec>
Switch(config)# spanning-tree rst max-age <sec>

仕様説明

Root Bridge 選定

MNOシリーズは、以下のコマンドでBridge Priorityを定義する事ができます。Priorityは16進数で指定し、デフォルト値はCisco機と全く同じ値である0x8000(32768)です。Cisco機と同様に、Priority値は0x1000(4096)の倍数で指定しなければならないという制約があります。

Switch(config)# spanning-tree mst priority lt;priority>

Cost 設定

以下のコマンドでSTPに関するコストを設定する事ができます。

Switch(config)# interface <interface>
Switch(config-if)# spanning-tree rst cost <cost>

重箱の隅をつつくような知識ですが、スパニングツリーはBPDUを受信したポートのコストが加算されます。運用上の理想は対向毎に同じコストを設定すべきですが、まれに(設定ミスや政治上の理由で)非対称がなコストになってしまう事があります。このような場合は、コストに関する知識を持っていると自信を持ってデバッグできます。

Port Priority 設定

以下のコマンドでSTPに関するPort Priorityを設定する事ができます。Cisco機と同様に、Port Priorityは16の倍数で指定する必要があります。

Switch(config)# interface <interface>
Switch(config-if)# spanning-tree rst port-priority <num>

非常に誤解している人が多いのですが、Port Priorityは対向機のPort Priorityが小さいポートが優先されます。初学者は自身のPort Priorityを元にRoot Bridgeが決まると勘違いしている人が多いので、注意して下さい。

タイマー設定

以下のコマンドでSTPに関するタイマーをチューニングする事ができます。

Switch(config)# spanning-tree rst hello-time <sec>
Switch(config)# spanning-tree rst forward-time <sec>
Switch(config)# spanning-tree rst max-age <sec>

STPに関するタイマーの決定権を持つのはRoot Bridgeです。forwarding-time, max-age等のパラメータはBPDUに含まれており、Root Bridge以外のスイッチ機器はRoot Bridgeのパラメータに追従する挙動をします。

動作確認環境

以下の構成で動作確認を行います。

構成図

 [SW1]
spanning-tree rst enable
spanning-tree rst version rstp

 [SW2]
spanning-tree mode rapid-pvst

初期設定の全文は以下を参照下さい。

SW1 config
! -- start of config file -- 
! -- Software Version : 2.0.0.85 -- 
!
enable
config
!
hostname SW1
console inactivity-timer 60
telnet-server inactivity-timer 60
ip http server
!
ip address 192.168.0.1 255.255.255.0
!
spanning-tree rst enable
spanning-tree rst version rstp
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/25
!
interface GigabitEthernet0/26
!
interface vlan1
member 1-26
exit
!
! -- end of configuration --
SW2 config

!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname SW2
!
boot-start-marker
boot-end-marker
!
enable password cisco
!
!
!
no aaa new-model
!
!
no ip domain-lookup
vtp mode transparent
!
!
crypto pki trustpoint TP-self-signed-1019362048
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-1019362048
 revocation-check none
 rsakeypair TP-self-signed-1019362048
!
!
crypto pki certificate chain TP-self-signed-1019362048
 certificate self-signed 01
  3082023C 308201A5 A0030201 02020101 300D0609 2A864886 F70D0101 04050030 
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274 
  69666963 6174652D 31303139 33363230 3438301E 170D3933 30333031 30303031 
  33375A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649 
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D31 30313933 
  36323034 3830819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281 
  8100DD26 F6443B16 21A92FA1 7C4E4395 4D7731C6 3A28F628 12D1B6B1 0DA016D1 
  6F814E4B FB1E19B8 17E561D5 9D11A930 395423C5 E01D45D4 855193EA C518116B 
  DBF1654D 6C136C03 89A7019F F8C3D084 19A7CD3F AD27F519 5ABBFC9F ECB56FDA 
  E3BC9408 8FE17469 16B3C6F1 63E5322F D14B6DE1 67DD99FF C890D50D 237708DA 
  AA0B0203 010001A3 64306230 0F060355 1D130101 FF040530 030101FF 300F0603 
  551D1104 08300682 04535732 2E301F06 03551D23 04183016 80141B26 E3B5765A 
  4C42859E BC8650E4 C85F9085 0BDB301D 0603551D 0E041604 141B26E3 B5765A4C 
  42859EBC 8650E4C8 5F90850B DB300D06 092A8648 86F70D01 01040500 03818100 
  DAF767F9 7F91267A 543197BE BB6D7AEB 0C89642A 5A5535BA 4133A58F 6FCAF28B 
  24758E72 DAF0B32D 7C63C48B 4607DDD4 C2D7D74F 4F90123B 96AEA4C4 B73F6D06 
  1600887A 934FB21E AFFADEE3 36542942 A51F5DEC 3C1BFD2A F5690C72 9C548E86 
  309191BB 3C962C42 E508990E 07DAA0F4 656B195F 06F91CAE DE497CB4 D086CB95
  quit
!
spanning-tree mode rapid-pvst
spanning-tree extend system-id
!
!
!
!
vlan internal allocation policy ascending
!
!
interface FastEthernet0
 no ip address
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface GigabitEthernet0/3
!
interface GigabitEthernet0/4
!
interface GigabitEthernet0/5
!
interface GigabitEthernet0/6
!
interface GigabitEthernet0/7
!
interface GigabitEthernet0/8
!
interface GigabitEthernet0/9
!
interface GigabitEthernet0/10
!
interface GigabitEthernet0/11
!
interface GigabitEthernet0/12
!
interface GigabitEthernet0/13
!
interface GigabitEthernet0/14
!
interface GigabitEthernet0/15
!
interface GigabitEthernet0/16
!
interface GigabitEthernet0/17
!
interface GigabitEthernet0/18
!
interface GigabitEthernet0/19
!
interface GigabitEthernet0/20
!
interface GigabitEthernet0/21
!
interface GigabitEthernet0/22
!
interface GigabitEthernet0/23
 switchport mode trunk
!
interface GigabitEthernet0/24
 switchport mode trunk
!
interface GigabitEthernet0/25
!
interface GigabitEthernet0/26
!
interface Vlan1
 ip address 192.168.0.2 255.255.255.0
!
ip http server
ip http secure-server
!
line con 0
 logging synchronous
line vty 0 4
 password cisco
 logging synchronous
 login
line vty 5 15
 password cisco
 logging synchronous
 login
!
end

Root Bridge 選定

設定前の動作確認

デフォルトの状態ではSW1側がRoot Bridgeになっている事を確認します。”CIST Root”と”CIST Bridge ID”の値が一致している事からSW1がRoot Bridgeである事が読み取れます。

 [SW1:MNO]
SW1# show spanning-tree rst config

 CIST Root Port:          0              Time Since Topology Change: 3160   Sec.
 CIST Root Path Cost:     0              Topology Change Count:      6
 CIST Root:          8000 00C08F2BB5F7
 CIST Regional Root Cost: 0              CIST Bridge ID:       8000 00C08F2BB5F7
 CIST Regional Root: 8000 00C08F2BB5F7   CIST Bridge Hello Time:    2     Sec.
                                         CIST Bridge Maximum Age:   20    Sec.
 CIST Hello Time:     2     Sec.         CIST Bridge Forward Delay: 15    Sec.
 CIST Maximum Age:    20    Sec.         Max Hop Count:             20
 CIST Forward Delay:  15    Sec.
SW1#

設定投入

SW2がRoot Bridgeになるよう、SW1のPriorityを下げます。

 [SW1:MNO]
spanning-tree mst priority 0x9000

設定後の動作確認

Root BridgeがSW1からSW2へ変わった事を確認します。”CIST Root”と”CIST Bridge ID”の異なる事からSW1がRoot Bridgeではなくなった事が分かります。

 [SW1:MNO]
SW1# show spanning-tree rst config

 CIST Root Port:          23             Time Since Topology Change: 23     Sec.
 CIST Root Path Cost:     200000         Topology Change Count:      7
 CIST Root:          8001 C4143CC23B00
 CIST Regional Root Cost: 0              CIST Bridge ID:       9000 00C08F2BB5F7
 CIST Regional Root: 9000 00C08F2BB5F7   CIST Bridge Hello Time:    2     Sec.
                                         CIST Bridge Maximum Age:   20    Sec.
 CIST Hello Time:     2     Sec.         CIST Bridge Forward Delay: 15    Sec.
 CIST Maximum Age:    20    Sec.         Max Hop Count:             20
 CIST Forward Delay:  15    Sec.
SW1#

Cost 設定

設定前の動作確認

SW1の状態を確認すると、コストが等しいため、Port Priorityが小さいFa0/23がForwardingになっている事が確認できます。

 [SW1:MNO]
SW1# show spanning-tree rst interface 23-24
  Port          : 23                 STP Status    : Enabled
  Link          : Up                 Trunk         : -
  Admin/OperEdge: False/False        Admin/OperPtoP: Auto /True
  Migration     : M/RSTP
  Port State    : Forwarding         Port Priority : 128
  Port Role     : Root               Port Path Cost: 200000(A)
  Desig. Root   : 8001 C4143CC23B00  Desig. Cost   : 0
  Desig. Bridge : 8001 C4143CC23B00  Desig. Port   : 80 17
  Regional Root : 8001 C4143CC23B00  Regional Cost : 0
  Guard         : Disabled

  Port          : 24                 STP Status    : Enabled
  Link          : Up                 Trunk         : -
  Admin/OperEdge: False/False        Admin/OperPtoP: Auto /True
  Migration     : M/RSTP
  Port State    : Discarding         Port Priority : 128
  Port Role     : Alternate          Port Path Cost: 200000(A)
  Desig. Root   : 8001 C4143CC23B00  Desig. Cost   : 0
  Desig. Bridge : 8001 C4143CC23B00  Desig. Port   : 80 18
  Regional Root : 8001 C4143CC23B00  Regional Cost : 0
  Guard         : Disabled

SW1#

設定投入

SW1にコストを設定し、Gi0/23ではなくGi0/24が優先されるように経路変更します。

この時注意するのが、Root Bridgeの位置です。現在SW2側がRoot Bridgeになっています。BPDUを受信したポートのCostが適用されるため、Costを設定すべきPortはSW1側です。

 [SW1:MNO]
interface FastEthernet0/23
 spanning-tree rst cost 200001

設定後の動作確認

SW1の状態を確認すると、コストが小さいFa0/24がForwardingになっている事が確認できます。Fa0/23経由からFa0/24経由に変わった事が分かります。

 [SW1:MNO]
SW1# show spanning-tree rst interface 23-24
  Port          : 23                 STP Status    : Enabled
  Link          : Up                 Trunk         : -
  Admin/OperEdge: False/False        Admin/OperPtoP: Auto /True
  Migration     : M/RSTP
  Port State    : Discarding         Port Priority : 128
  Port Role     : Alternate          Port Path Cost: 200001
  Desig. Root   : 8001 C4143CC23B00  Desig. Cost   : 0
  Desig. Bridge : 8001 C4143CC23B00  Desig. Port   : 80 17
  Regional Root : 8001 C4143CC23B00  Regional Cost : 0
  Guard         : Disabled

  Port          : 24                 STP Status    : Enabled
  Link          : Up                 Trunk         : -
  Admin/OperEdge: False/False        Admin/OperPtoP: Auto /True
  Migration     : M/RSTP
  Port State    : Forwarding         Port Priority : 128
  Port Role     : Root               Port Path Cost: 200000(A)
  Desig. Root   : 8001 C4143CC23B00  Desig. Cost   : 0
  Desig. Bridge : 8001 C4143CC23B00  Desig. Port   : 80 18
  Regional Root : 8001 C4143CC23B00  Regional Cost : 0
  Guard         : Disabled

SW1#

Port Priority 設定

事前準備

MNOシリーズに投入したPort Priorityの値が機能しているかどうか確かめるため、SW1をRoot Bridgeとします。

SW2はまずCostを元にRoot Portの選定を試みます。Costが等しい場合は、対向機器のSW1のPort Priorityを元にRoot Portを選定します。このような挙動をするため、Port Priorityの動作確認を行うためにはSW1側をRoot Bridgeとする必要があります。

 [SW1:MNO]
spanning-tree rst priority 0x0000

設定前の動作確認

SW2の状態を確認すると、コストが等しいため、SW1側のBridge Priorityが小さいGi0/23がFWDになっている事が確認できます。対向機器のPort Priorityを元にRoot Bridgeが選定されます。

 [SW2:cisco]
SW2#show spanning-tree vlan 1

VLAN0001
  Spanning tree enabled protocol rstp
  Root ID    Priority    0
             Address     00c0.8f2b.b5f7
             Cost        19
             Port        23 (GigabitEthernet0/23)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32769  (priority 32768 sys-id-ext 1)
             Address     c414.3cc2.3b00
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  300 sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Gi0/23              Root FWD 19        128.23   P2p
Gi0/24              Altn BLK 19        128.24   P2p


SW2#

あまり知られていない確認手法ですが、”show spanning-tree vlan <num> detail”コマンドで対向機器のport priorityを確認する事ができます。”Designated port id is”と書かれている部分に注目すると、デフォルト値の128とポート番号が組み合させた値が記載されている事が分かります。

 [SW2:cisco]
SW2#show spanning-tree vlan 1 detail

 VLAN0001 is executing the rstp compatible Spanning Tree protocol
  Bridge Identifier has priority 32768, sysid 1, address c414.3cc2.3b00
  Configured hello time 2, max age 20, forward delay 15, transmit hold-count 6
  Current root has priority 0, address 00c0.8f2b.b5f7
  Root port is 23 (GigabitEthernet0/23), cost of root path is 19
  Topology change flag not set, detected flag not set
  Number of topology changes 17 last change occurred 00:03:30 ago
          from GigabitEthernet0/23
  Times:  hold 1, topology change 35, notification 2
          hello 2, max age 20, forward delay 15
  Timers: hello 0, topology change 0, notification 0, aging 300

 Port 23 (GigabitEthernet0/23) of VLAN0001 is root forwarding
   Port path cost 19, Port priority 128, Port Identifier 128.23.
   Designated root has priority 0, address 00c0.8f2b.b5f7
   Designated bridge has priority 0, address 00c0.8f2b.b5f7
   Designated port id is 128.23, designated path cost 0
   Timers: message age 16, forward delay 0, hold 0
   Number of transitions to forwarding state: 4
   Link type is point-to-point by default
   BPDU: sent 843, received 3427

 Port 24 (GigabitEthernet0/24) of VLAN0001 is alternate blocking
   Port path cost 19, Port priority 128, Port Identifier 128.24.
   Designated root has priority 0, address 00c0.8f2b.b5f7
   Designated bridge has priority 0, address 00c0.8f2b.b5f7
   Designated port id is 128.24, designated path cost 0
   Timers: message age 15, forward delay 0, hold 0

SW2#

設定投入

MNOシリーズにPort Priorityの定義し、Gi0/23経由からGi0/24経由に変更します。

 [SW1:MNO]
interface FastEthernet0/24
 spanning-tree rst port-priority 0

設定後の動作確認

SW2のポートの状態を確認します。Gi0/23経由からGi0/24経由に変わった事を確認します。Gi0/24がFWDとなった事を確認して下さい。

 [SW2:cisco]
SW2#show spanning-tree vlan 1

VLAN0001
  Spanning tree enabled protocol rstp
  Root ID    Priority    0
             Address     00c0.8f2b.b5f7
             Cost        19
             Port        24 (GigabitEthernet0/24)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32769  (priority 32768 sys-id-ext 1)
             Address     c414.3cc2.3b00
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  300 sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Gi0/23              Altn BLK 19        128.23   P2p
Gi0/24              Root FWD 19        128.24   P2p


SW2#

SW2から見て、SW1からAdvertiseされたport priorityが変わった事を確認します。port24の”Designated port id is”が128.24から0.24に減った事を確認します。

 [SW2:cisco]
SW2#show spanning-tree vlan 1 detail

 VLAN0001 is executing the rstp compatible Spanning Tree protocol
  Bridge Identifier has priority 32768, sysid 1, address c414.3cc2.3b00
  Configured hello time 2, max age 20, forward delay 15, transmit hold-count 6
  Current root has priority 0, address 00c0.8f2b.b5f7
  Root port is 24 (GigabitEthernet0/24), cost of root path is 19
  Topology change flag set, detected flag not set
  Number of topology changes 18 last change occurred 00:00:27 ago
          from GigabitEthernet0/24
  Times:  hold 1, topology change 35, notification 2
          hello 2, max age 20, forward delay 15
  Timers: hello 0, topology change 7, notification 0, aging 300

 Port 23 (GigabitEthernet0/23) of VLAN0001 is alternate blocking
   Port path cost 19, Port priority 128, Port Identifier 128.23.
   Designated root has priority 0, address 00c0.8f2b.b5f7
   Designated bridge has priority 0, address 00c0.8f2b.b5f7
   Designated port id is 128.23, designated path cost 0
   Timers: message age 16, forward delay 0, hold 0
   Number of transitions to forwarding state: 4
   Link type is point-to-point by default
   BPDU: sent 843, received 3462

 Port 24 (GigabitEthernet0/24) of VLAN0001 is root forwarding
   Port path cost 19, Port priority 128, Port Identifier 128.24.
   Designated root has priority 0, address 00c0.8f2b.b5f7
   Designated bridge has priority 0, address 00c0.8f2b.b5f7
   Designated port id is 0.24, designated path cost 0
   Timers: message age 16, forward delay 0, hold 0
   Number of transitions to forwarding state: 5
   Link type is point-to-point by default
   BPDU: sent 954, received 3663

SW2#

タイマーのチューニング

設定投入

SW1のスパニングツリーに関するタイマー設定を変更します。

 [SW1:MNO]
spanning-tree rst hello-time 1
spanning-tree rst forward-time 11
spanning-tree rst max-age 6

動作確認

SW1のタイマー設定がSW2に伝播した事を確認します。

 [SW2:Cisco]
SW2#show spanning-tree vlan 1

VLAN0001
  Spanning tree enabled protocol rstp
  Root ID    Priority    0
             Address     00c0.8f2b.b5f7
             Cost        19
             Port        24 (GigabitEthernet0/24)
             Hello Time   1 sec  Max Age  6 sec  Forward Delay 11 sec

  Bridge ID  Priority    32769  (priority 32768 sys-id-ext 1)
             Address     c414.3cc2.3b00
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  300 sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Gi0/23              Altn BLK 19        128.23   P2p
Gi0/24              Root FWD 19        128.24   P2p


SW2#
タイトルとURLをコピーしました