Panasonic MNO VLAN 設定

スポンサーリンク

パナソニックMNOシリーズではタグVLAN, ポートVLANを設定する方法について説明します。MNOシリーズは、標準規格である802.1qを採用しているため、Cisco機などと問題なく疎通する事ができます。

コマンド一覧

このシナリオで重要なコマンド一覧は以下の通りです。

Switch(config)# interface vlan<num>
Switch(config-if)# member <port_list>
Switch(config-if)# management

Switch(config)# interface Fa<num>
Switch(config-if)# PVID <num>
Switch(config-if)# frame-type [ all | tag-only ]

仕様説明

vlan memberの定義

パナソニックMNOシリーズには、cisco機のようなaccess port, trunk portに相当する概念はありません。代わりに、以下のコマンドでどのポートがどのvlanに所属するかを定義する事ができます。

Switch(config)# interface vlan<num>
Switch(config-if)# member <port_list>

以下設定を具体例を挙げて説明します。

interface vlan1
 member 1-4
!
interface vlan2
 member 1-4
!
interface vlan3
 member 1-3

このような設定の場合、port1-3はvlan 1-3を許可しますが、port4はvlan 1,2を許可するようになります。vlan memberを定義する事によって、許可するvlanを制限する事ができます。cisco機の”switchport trunk allowed vlan”に相当する概念と思って下さい。

native vlanの定義

以下のコマンドでnative vlanを定義する事ができます。パナソニックMNOシリーズにはaccess portに相当する概念はありませんので、Edge port(端末と接続するポート)にnative vlanを定義する事によって、端末を特定のvlanに所属させる事ができます。

なお、ヘルプストリングでISLと表示されますが、ISL tagが付与されるわけではありません。非native vlanは802.1q(dot1q)タグが付与されます。

Switch(config)# interface Fa<num>
Switch(config-if)# PVID ?
 <1-4094>  ISL VLAN index

Switch(config-if)# PVID <num>

frame-type

パナソニックMNOスイッチは、タグなしフレームを許可するかどうかを指定する事ができます。all(Admit All)がタグなしフレームを許可する設定で、“tag-only”がタグなしフレームを拒否する設定です。

Switch(config)# interface Fa<num>
Switch(config-if)# frame-type [ all | tag-only ]

CLI版のデフォルト設定は”all”なので特に心配は要りません。が、GUI版はデフォルト設定が”Tagged Only”になっていますのでやや注意を払って下さい。

Panasonic MNO tagged only

マネジメントVLAN

パナソニックMNOスイッチはマネジメントVLANという概念があり、管理機能(telnet, 管理画面)などへログイン可能なVLANかどうかを決める設定です。デフォルトでVLAN1のみマネジメントが有効になっています。言い換えれば、VLAN1経由のパケットのみ管理機能へのアクセスを許可しているという意味です。

マネジメントVLANを有効にするには以下のようなコマンドを使います。

Switch(config)# interface vlan<num>
Switch(config-if)# management

もう少し具体的な例を示します。以下のような設定にすれば、vlan1-3から管理機能へアクセスできるようになります。

interface vlan2
 management
!
interface vlan3
 management

動作確認環境

以下の構成で動作確認を行います。SW1はパナソニックNMOシリーズで、SW2はcisco catalyst 2960S(IOS 12.5)のベンダー混在環境です。

構成図

 [SW1:MNO]
hostname SW1
console inactivity-timer 60
telnet-server inactivity-timer 60
ip http server
!
ip address 192.168.0.1 255.255.255.0
ip default-gateway 192.168.0.254

 [SW2:cisco]
interface GigabitEthernet0/24
 switchport mode trunk
!
interface Vlan1
 ip address 192.168.0.2 255.255.255.0
!
interface Vlan2
 no ip address

初期設定の全文は以下を参照下さい。

SW1 config
! -- start of config file -- 
! -- Software Version : 2.0.0.85 -- 
!
enable
config
!
hostname SW1
console inactivity-timer 60
telnet-server inactivity-timer 60
ip http server
!
ip address 192.168.0.1 255.255.255.0
ip default-gateway 192.168.0.254
!
spanning-tree rst version rstp
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/25
!
interface GigabitEthernet0/26
!
interface vlan1
member 1-26
exit
!
! -- end of configuration --
SW2 config

!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname SW2
!
boot-start-marker
boot-end-marker
!
enable password cisco
!
!
!
no aaa new-model
!
!
no ip domain-lookup
vtp mode transparent
!
!
crypto pki trustpoint TP-self-signed-1019362048
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-1019362048
 revocation-check none
 rsakeypair TP-self-signed-1019362048
!
!
crypto pki certificate chain TP-self-signed-1019362048
 certificate self-signed 01
  3082023F 308201A8 A0030201 02020101 300D0609 2A864886 F70D0101 04050030 
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274 
  69666963 6174652D 31303139 33363230 3438301E 170D3933 30333031 30303031 
  34305A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649 
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D31 30313933 
  36323034 3830819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281 
  8100DD26 F6443B16 21A92FA1 7C4E4395 4D7731C6 3A28F628 12D1B6B1 0DA016D1 
  6F814E4B FB1E19B8 17E561D5 9D11A930 395423C5 E01D45D4 855193EA C518116B 
  DBF1654D 6C136C03 89A7019F F8C3D084 19A7CD3F AD27F519 5ABBFC9F ECB56FDA 
  E3BC9408 8FE17469 16B3C6F1 63E5322F D14B6DE1 67DD99FF C890D50D 237708DA 
  AA0B0203 010001A3 67306530 0F060355 1D130101 FF040530 030101FF 30120603 
  551D1104 0B300982 07537769 7463682E 301F0603 551D2304 18301680 141B26E3 
  B5765A4C 42859EBC 8650E4C8 5F90850B DB301D06 03551D0E 04160414 1B26E3B5 
  765A4C42 859EBC86 50E4C85F 90850BDB 300D0609 2A864886 F70D0101 04050003 
  8181003D 87BF3741 7AD3A493 A60828C1 2A349582 B5FC36AE B4D997E3 83A55F19 
  790CE9A2 7AA9F4AD E1C4AE3D E216C750 73D7FCEA D26D333F 96BC1964 09F168E0 
  0FDFED7B CC46B50D 2E229728 3A9887EC 50041F57 0099C0AC CE6773FB CF12A7BA 
  6C4D7566 F244033F C1268E8B 4DE7E1C5 06A9E0EF 811ECFFD 2F6945B0 A1776E01 CBB867
  quit
spanning-tree mode pvst
spanning-tree extend system-id
!
!
!
!
vlan internal allocation policy ascending
!
vlan 2 
!
!
interface FastEthernet0
 no ip address
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface GigabitEthernet0/3
!
interface GigabitEthernet0/4
!
interface GigabitEthernet0/5
!
interface GigabitEthernet0/6
!
interface GigabitEthernet0/7
!
interface GigabitEthernet0/8
!
interface GigabitEthernet0/9
!
interface GigabitEthernet0/10
!
interface GigabitEthernet0/11
!
interface GigabitEthernet0/12
!
interface GigabitEthernet0/13
!
interface GigabitEthernet0/14
!
interface GigabitEthernet0/15
!
interface GigabitEthernet0/16
!
interface GigabitEthernet0/17
!
interface GigabitEthernet0/18
!
interface GigabitEthernet0/19
!
interface GigabitEthernet0/20
!
interface GigabitEthernet0/21
!
interface GigabitEthernet0/22
!
interface GigabitEthernet0/23
!
interface GigabitEthernet0/24
 switchport mode trunk
!
interface GigabitEthernet0/25
!
interface GigabitEthernet0/26
!
interface Vlan1
 ip address 192.168.0.2 255.255.255.0
!
interface Vlan2
 no ip address
!
ip http server
ip http secure-server
!
line con 0
 logging synchronous
line vty 0 4
 password cisco
 logging synchronous
 login
line vty 5 15
 password cisco
 logging synchronous
 login
!
end

vlan memberの定義

設定投入

SW1の全ポートをvlan2のメンバーに加える事によって、全てのポートがvlan 1,2を通信できるようにします。

 [SW1:MNO]
interface vlan2
 member 1-24

この時点での疎通確認は行いません。

native vlanの定義

設定投入

SW1のport2について、native vlanを2とします。このような設定を投入する事によって、Host100がvlan1に所属し、Host200がvlan2に所属するようにします。

 [SW1:MNO]
interface Fa0/2
 PVID 2

疎通確認 vlan 1

SW2からの疎通確認を行います。vlan1から同一VLANに所属するHost100へは疎通可能である事を確認します。また、異なるVLANに所属するHost200へは疎通不能である事を確認します。

 [SW2:cisco]
SW2#ping 192.168.0.100 timeout 1 source Vlan 1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.0.100, timeout is 1 seconds:
Packet sent with a source address of 192.168.0.2
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/6 ms
SW2#
SW2#
SW2#ping 192.168.0.200 timeout 1 source Vlan 1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.0.200, timeout is 1 seconds:
Packet sent with a source address of 192.168.0.2
.....
Success rate is 0 percent (0/5)
SW2#

疎通確認 vlan 2

vlan2からの疎通を確認するため、SW2の設定を以下のように変更します。

 [SW2:cisco]
interface Vlan1
 no ip address
!
interface Vlan2
 ip address 192.168.0.2 255.255.255.0
 no shutdown

vlan2から異なるVLANに所属するHost100へは疎通不能である事を確認します。また、同一VLANに所属するHost200へは疎通可能である事を確認します。

 [SW2:cisco]
SW2#ping 192.168.0.100 timeout 1 source Vlan 2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.0.100, timeout is 1 seconds:
Packet sent with a source address of 192.168.0.2
.....
Success rate is 0 percent (0/5)
SW2#
SW2#
SW2#ping 192.168.0.200 timeout 1 source Vlan 2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.0.200, timeout is 1 seconds:
Packet sent with a source address of 192.168.0.2
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/4/10 ms
SW2#

マネジメントVLAN

設定前の動作確認

初期状態では、VLAN2からSW1へのpingが届かない事が分かります。これはマネジメントVLANがVLAN1のみ有効になっているためです。

C:\\Users\\Host200>ping 192.168.0.1

192.168.0.1 に ping を送信しています 32 バイトのデータ:
172.16.24.4 からの応答: 宛先ホストに到達できません。
172.16.24.4 からの応答: 宛先ホストに到達できません。
172.16.24.4 からの応答: 宛先ホストに到達できません。
172.16.24.4 からの応答: 宛先ホストに到達できません。

192.168.0.1 の ping 統計:
    パケット数: 送信 = 4、受信 = 4、損失 = 0 (0% の損失)、

C:\\Users\\Host200>

マネジメントVLAN有効化

SW1のVLAN2について、マネジメントVLANを有効にします。

 [SW1:MNO]
interface vlan2
 management

設定前の動作確認

VLAN2からSW1へのpingが届くようになった事を確認します。

C:\\Users\\Host200>ping 192.168.0.1

192.168.0.1 に ping を送信しています 32 バイトのデータ:
192.168.0.1 からの応答: バイト数 =32 時間 =4ms TTL=64
192.168.0.1 からの応答: バイト数 =32 時間 =4ms TTL=64
192.168.0.1 からの応答: バイト数 =32 時間 =4ms TTL=64
192.168.0.1 からの応答: バイト数 =32 時間 =4ms TTL=64

192.168.0.1 の ping 統計:
    パケット数: 送信 = 4、受信 = 4、損失 = 0 (0% の損失)、
ラウンド トリップの概算時間 (ミリ秒):
    最小 = 4ms、最大 = 4ms、平均 = 4ms

C:\\Users\\Host200>
タイトルとURLをコピーしました