Cisco IOS Layer2 – PPP LCP NCPのプロトコル理解

スポンサーリンク

PPPはLCP, NCPの2階層のプロトコルによって成り立っています。LCPやNCPを意識した設定を行う事はありませんが、この仕組みを理解しておくとトラブルシュートの手助けとなります。

構成図

以下の環境で動作確認を行います。

         s0/0    s0/0
 +--------+.1    .2+--------+
 |   R1   +--------+   R2  | 
 +--------+        +--------+
        192.168.12.0/24

 [R1]
hostname R1

 [R2]
hostname R2

初期設定はhostnameのみですが、念のため設定全文を掲載します。

R1
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Serial0/0
 no ip address
 shutdown
 serial restart-delay 0
 no fair-queue
!
interface Serial0/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
ip http server
ip forward-protocol nd
!
!
!
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
 login
!
!
end
R2
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Serial0/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
ip http server
ip forward-protocol nd
!
!
!
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
 login
!
!
end

仕様説明

LCP

LCPはPPPの下位層のプロトコルで以下の役割を果たします。

  • 認証
  • 圧縮
  • マルチリンク
  • コールバック
  • エラー検知

LCPを問題なく確立できている場合は、以下のように“Open”との出力が確認できます。

Router#show interfaces Serial 0/0 | include LCP
  Encapsulation PPP, LCP Open
Router#

認証, マルチリンク, 圧縮形式などに設定の不一致がある場合は、以下のように“Listen”, “TERMsent”などの表示が確認できます。

Router#show interfaces Serial 0/0 | include LCP
  Encapsulation PPP, LCP TERMsent, crc 16, loopback not set
Router#

LCPより下のLayerのトラブルである場合は、“Closed”と表示されます。

Router#show interfaces Serial 0/0 | include LCP
  Encapsulation PPP, LCP Closed, crc 16, loopback not set
Router#

NCP

NCPは上位層ネットワークとのネゴシエーションを行います。上位層ネットワークの種類により、NCPは以下のように分類されています。

NCP 説明
IPCP IPに関するネゴシエーションを行います。
BCP Bridge Frameに関するネゴシエーションを行います。
IPXCP IPXに関するネゴシエーションを行います。
ATALKCP Apple Talkに関するネゴシエーションを行います。

IPCP

設定投入

以下のような設定を投入し、R1, R2間で疎通可能な状態にします。

 [R1]
interface Serial0/0
 ip address 192.168.12.1 255.255.255.0
 encapsulation ppp
 clock rate 64000
 no shutdown

 [R2]
interface Serial0/0
 ip address 192.168.32.1 255.255.255.0
 encapsulation ppp
 no shutdown

動作確認

IP通信を行うためのネゴシエーションは、IPCPと呼ばれます。showコマンドで、IPCPとの出力を確認して下さい。

 [R1]
R1#show interfaces Serial 0/0 | i LCP|Open
  Encapsulation PPP, LCP Open
  Open: IPCP, CDPCP, crc 16, loopback not set
R1#

IPXCP

設定投入

以下のような設定を投入し、PPP上でIPXによる通信が可能なようにします。

 [R1]
ipx routing
!
interface Serial0/0
 encapsulation ppp
 ipx network 12

 [R2]
ipx routing
!
interface Serial0/0
 encapsulation ppp
 ipx network 12

動作確認

IPX通信を行うためのネゴシエーションは、IPXCPと呼ばれます。showコマンドで、IPXCPとの出力を確認して下さい。

 [R1]
R1#show interfaces Serial 0/0 | i LCP|Open
  Encapsulation PPP, LCP Open
  Open: IPCP, CDPCP, IPXCP, crc 16, loopback not set
R1#

R1, R2間で疎通可能である事も確認しましょう。

 [R2]
R2#show ipx interface Serial 0/0 | include address
  IPX address is 12.0000.0c02.667c [up]
R2#

 [R1]
R1#ping 12.0000.0c02.667c

Type escape sequence to abort.
Sending 5, 100-byte IPX Novell Echoes to 12.0000.0c02.667c, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/32/68 ms
R1#

BCP

設定投入

以下のような設定を投入し、PPP上でBridge Frameによる通信が可能なようにします。

 [R1]
bridge irb
bridge 1 protocol ieee
bridge 1 route ip
!
interface Serial0/0
 bridge-group 1
!
interface BVI1
 ip address 192.168.21.1 255.255.255.0

 [R2]
bridge irb
bridge 1 protocol ieee
bridge 1 route ip
!
interface Serial0/0
 bridge-group 1
!
interface BVI1
 ip address 192.168.21.2 255.255.255.0

動作確認

Bridge Frame通信を行うためのネゴシエーションは、BCPと呼ばれます。showコマンドで、BCPとの出力を確認して下さい。

 [R1]
R1#show interfaces Serial 0/0 | i LCP|Open
  Encapsulation PPP, LCP Open
  Open: IPCP, CDPCP, IPXCP, BCP, crc 16, loopback not set
R1#
R1#ping 192.168.21.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.21.2, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 20/51/88 ms
R1#
タイトルとURLをコピーしました