Cisco IOS ルーティング – マルチエリアのOSPF LSAまとめ

スポンサーリンク

OSPF マルチエリアで使用されるLSAについてまとめます。基礎的な設定を行うのにLSAの知識は必要ありませんが、LSAを理解している事はトラブルシューティングで大いに役立ちます。ここではマルチエリアで使われるLSAについて説明します。

概要

OSPF LSAについてまとめます。Ciscoルータが生成するLSAは以下6種類です。ここでは、LSA type 3, type4, type5, type7についてまとめます。

Type Name 生成元 説明 Routing Table
1 Router LSA 全ルータ ルータに関する情報 O
2 Network LSA DRルータ リンクに関する情報 O
3 Summary LSA ABR 各エリア毎の情報 O IA
4 ASBR Summary LSA ASR ABRからASBRまでの情報 O IA
5 AS External LSA ASBR 再配送された情報 O E1, O E2
7 NSSA External LSA ASBR 再配送された情報 O N1, O N2

構成図

以下の環境で動作確認を行います。

       RIP     OSPF Area 12           OSPF Area 0       OSPF Area 34 nssa  EIGRP
    <------><----------------><------------------------><----------------><----->
           +--------+        +--------+        +--------+        +--------+
       ----+   R1   +--------+   R2   +--------+   R3   +--------+   R4   +----
         .1+--------+.1    .2+--------+.2    .3+--------+.3    .4+--------+.4
         e0/1      e0/0    e0/1      e0/0    e0/1      e0/0    e0/1      e0/0
 192.168.1.0/24   192.168.12.0/24   192.168.23.0/24   192.168.34.0/24   192.168.4.0/24

          R1 Loopback0      R2 Loopback0      R2 Loopback0      R2 Loopback0
          10.1.1.1/32       10.2.2.2/32       10.3.3.3/32       10.4.4.4/32
 [R1]
router ospf 1
 redistribute rip subnets
 network 10.1.1.1 0.0.0.0 area 1
 network 192.168.12.1 0.0.0.0 area 12
!
router rip
 version 2
 redistribute ospf 1
 network 192.168.1.0
 no auto-summary

 [R2]
router ospf 1
 network 10.2.2.2 0.0.0.0 area 0
 network 192.168.12.2 0.0.0.0 area 12
 network 192.168.23.2 0.0.0.0 area 0

 [R3]
router ospf 1
 area 34 nssa no-summary
 network 10.3.3.3 0.0.0.0 area 0
 network 192.168.23.3 0.0.0.0 area 0
 network 192.168.34.3 0.0.0.0 area 34

 [R4]
router eigrp 10
 redistribute ospf 1 metric 1 1 1 1 1
 network 192.168.4.4 0.0.0.0
 no auto-summary
!
router ospf 1
 area 34 nssa
 redistribute eigrp 10 subnets
 network 10.4.4.4 0.0.0.0 area 34
 network 192.168.34.4 0.0.0.0 area 34

設定全文は下記ファイルです。

R1
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 10.1.1.1 255.255.255.255
!
interface Ethernet0/0
 ip address 192.168.12.1 255.255.255.0
 half-duplex
!
interface Ethernet0/1
 ip address 192.168.1.1 255.255.255.0
 half-duplex
 no keepalive
!
interface Ethernet0/2
 no ip address
 shutdown
 half-duplex
!
interface Ethernet0/3
 no ip address
 shutdown
 half-duplex
!
!
router ospf 1
 log-adjacency-changes
 redistribute rip subnets
 network 10.1.1.1 0.0.0.0 area 1
 network 192.168.12.1 0.0.0.0 area 12
!
router rip
 version 2
 redistribute ospf 1
 network 192.168.1.0
 no auto-summary
!
ip http server
ip forward-protocol nd
!
!
!
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
 login
!
!
end
R2
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 10.2.2.2 255.255.255.255
!
interface Ethernet0/0
 ip address 192.168.23.2 255.255.255.0
 half-duplex
!
interface Ethernet0/1
 ip address 192.168.12.2 255.255.255.0
 half-duplex
!
interface Ethernet0/2
 no ip address
 shutdown
 half-duplex
!
interface Ethernet0/3
 no ip address
 shutdown
 half-duplex
!
!
router ospf 1
 log-adjacency-changes
 network 10.2.2.2 0.0.0.0 area 0
 network 192.168.12.2 0.0.0.0 area 12
 network 192.168.23.2 0.0.0.0 area 0
!
ip http server
ip forward-protocol nd
!
!
!
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
 login
!
!
end
R3
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 10.3.3.3 255.255.255.255
!
interface Ethernet0/0
 ip address 192.168.34.3 255.255.255.0
 half-duplex
!
interface Ethernet0/1
 ip address 192.168.23.3 255.255.255.0
 half-duplex
!
interface Ethernet0/2
 no ip address
 shutdown
 half-duplex
!
interface Ethernet0/3
 no ip address
 shutdown
 half-duplex
!
!
router ospf 1
 log-adjacency-changes
 area 34 nssa no-summary
 network 10.3.3.3 0.0.0.0 area 0
 network 192.168.23.3 0.0.0.0 area 0
 network 192.168.34.3 0.0.0.0 area 34
!
ip http server
ip forward-protocol nd
!
!
!
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
 login
!
!
end
R4
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R4
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 10.4.4.4 255.255.255.255
!
interface Ethernet0/0
 ip address 192.168.4.4 255.255.255.0
 half-duplex
 no keepalive
!
interface Ethernet0/1
 ip address 192.168.34.4 255.255.255.0
 half-duplex
!
interface Ethernet0/2
 no ip address
 shutdown
 half-duplex
!
interface Ethernet0/3
 no ip address
 shutdown
 half-duplex
!
!
router eigrp 10
 redistribute ospf 1 metric 1 1 1 1 1
 network 192.168.4.4 0.0.0.0
 no auto-summary
!
router ospf 1
 log-adjacency-changes
 area 34 nssa
 redistribute eigrp 10 subnets
 network 10.4.4.4 0.0.0.0 area 34
 network 192.168.34.4 0.0.0.0 area 34
!
ip http server
ip forward-protocol nd
!
!
!
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
 login
!
!
end

OSPF LSA

type 3 Summary LSA

Single AreaのLSAは、Router LSA, Network LSAをやりとりしてトポロジを形成します。もし、全エリアのトポロジを形成してしまうと膨大なメモリを消費してしまいます。そこで、他のエリアはlinkに対するmetricのみを通知するようにしメモリを節約するような仕様になっております。このようにlinkに対するmetricを通知するLSAは”Summary LSA”と呼ばれています。

R2, R3間のSummary LSAを観察します。

Frame 28: 138 bytes on wire (1104 bits), 138 bytes captured (1104 bits)
Ethernet II, Src: cc:02:16:74:00:01 (cc:02:16:74:00:01), Dst: cc:01:16:18:00:00 (cc:01:16:18:00:00)
Internet Protocol Version 4, Src: 192.168.23.3 (192.168.23.3), Dst: 192.168.23.2 (192.168.23.2)
Open Shortest Path First
    OSPF Header
    LS Update Packet
        Number of LSAs: 2
        LS Type: Router-LSA
        LS Type: Summary-LSA (IP network)
            LS Age: 36 seconds
            Do Not Age: False
            Options: 0x22 (DC, E)
            Link-State Advertisement Type: Summary-LSA (IP network) (3)
            Link State ID: 192.168.34.0
            Advertising Router: 10.3.3.3 (10.3.3.3)
            LS Sequence Number: 0x80000001
            LS Checksum: 0x2b69
            Length: 28
            Netmask: 255.255.255.0
            Metric: 10

Summary LSAにはlinkに対するmetricの情報が含まれています。具体的には以下の通りです。

  • Link-State ID (リンクのネットワークアドレス)
  • Netmask (リンクのサブネットマスク)
  • Metric
  • Advertising Router

type 4 ASBR Summary LSA, type 5 AS External LSA

OSPF以外のドメインから再配送されたルートは、type 4 ASBR Summary LSAとtype 5 AS External LSAによってルーティング情報が形成されます。

type 4 ASBR Summary LSAはABRからASBRまでのmetricを表した情報でABRが生成します。type 3 LSAと殆ど同じ情報の形式で、相違点はLink-State Advertisement Typeが4である事とNetmaskが0.0.0.0である事です。

以下はR2, R3で観測されたASBR Summary LSAです。Area 0 からASBR(R1)までの距離を表しています。

Frame 50: 90 bytes on wire (720 bits), 90 bytes captured (720 bits)
Ethernet II, Src: cc:01:16:18:00:00 (cc:01:16:18:00:00), Dst: IPv4mcast_00:00:05 (01:00:5e:00:00:05)
Internet Protocol Version 4, Src: 192.168.23.2 (192.168.23.2), Dst: 224.0.0.5 (224.0.0.5)
Open Shortest Path First
    OSPF Header
    LS Update Packet
        Number of LSAs: 1
        LS Type: Summary-LSA (ASBR)
            LS Age: 1 seconds
            Do Not Age: False
            Options: 0x22 (DC, E)
            Link-State Advertisement Type: Summary-LSA (ASBR) (4)
            Link State ID: 10.1.1.1
            Advertising Router: 10.2.2.2 (10.2.2.2)
            LS Sequence Number: 0x80000001
            LS Checksum: 0xb75d
            Length: 28
            Netmask: 0.0.0.0
            Metric: 10

type 5 AS External LSAは外部ドメインのmetricを表します。このtype 4のmetricとtype 5のmetricの両方の値を用いてルーティング情報が形成されます。

type 5 AS External LSAはASBRによって生成され各エリアに伝播します。以下はR2, R3間で観測されたAS External LSAです。

Frame 42: 98 bytes on wire (784 bits), 98 bytes captured (784 bits)
Ethernet II, Src: cc:01:16:18:00:00 (cc:01:16:18:00:00), Dst: IPv4mcast_00:00:05 (01:00:5e:00:00:05)
Internet Protocol Version 4, Src: 192.168.23.2 (192.168.23.2), Dst: 224.0.0.5 (224.0.0.5)
Open Shortest Path First
    OSPF Header
    LS Update Packet
        Number of LSAs: 1
        LS Type: AS-External-LSA (ASBR)
            LS Age: 44 seconds
            Do Not Age: False
            Options: 0x20 (DC)
            Link-State Advertisement Type: AS-External-LSA (ASBR) (5)
            Link State ID: 192.168.1.0
            Advertising Router: 10.1.1.1 (10.1.1.1)
            LS Sequence Number: 0x80000001
            LS Checksum: 0xbb6d
            Length: 36
            Netmask: 255.255.255.0
            External Type: Type 2 (metric is larger than any other link state path)
            Metric: 20
            Forwarding Address: 0.0.0.0
            External Route Tag: 0

AS External LSAにはlinkに対するmetricの情報が含まれています。具体的には以下の通りです。

  • Link-State ID (リンクのネットワークアドレス)
  • Netmask (リンクのサブネットマスク)
  • Metric
  • Advertising Router
  • Forwarding Address : このアドレス宛てにパケットが転送されます。0.0.0.0の場合はAdvertising Router宛てに転送されます
  • Metric Type : 1の場合は内部metricと外部metricの合計によって比較され、2の場合は外部metricの値が優先的に比較されます。

type 7 NSSA External LSA

type 7 NSSA External LSAはNSSAにおける外部ルートを表すLSAです。NSSA内では、デフォルトルート以外のSummary LSA, ASBR Summary LSA, AS External LSAが禁止されています。そこで、type 7 NSSA External LSAを用いて外部ルートを伝播させます。

以下はR3, R4間で観測されたNSSA External LSAです。Area 12の場合と異なり、Forwarding Addressの値が0.0.0.0ではない事に注意して下さい。これは、type 4 AS Summary LSAがNSSA内部を伝播できないため、Forwarding Addressを用いてASBRのアドレスを通知するしかないためです。

Frame 42: 146 bytes on wire (1168 bits), 146 bytes captured (1168 bits)
Ethernet II, Src: cc:03:17:60:00:01 (cc:03:17:60:00:01), Dst: cc:02:17:60:00:00 (cc:02:17:60:00:00)
Internet Protocol Version 4, Src: 192.168.34.4 (192.168.34.4), Dst: 192.168.34.3 (192.168.34.3)
Open Shortest Path First
    OSPF Header
    LS Update Packet
        Number of LSAs: 2
        LS Type: Router-LSA
        LS Type: NSSA AS-External-LSA
            LS Age: 60 seconds
            Do Not Age: False
            Options: 0x28 (DC, NP)
            Link-State Advertisement Type: NSSA AS-External-LSA (7)
            Link State ID: 192.168.4.0
            Advertising Router: 10.4.4.4 (10.4.4.4)
            LS Sequence Number: 0x80000001
            LS Checksum: 0xd12b
            Length: 36
            Netmask: 255.255.255.0
            External Type: Type 2 (metric is larger than any other link state path)
            Metric: 20
            Forwarding Address: 10.4.4.4
            External Route Tag: 0

type 7 NSSA External LSAが使われるのはNSSA内部のみです。NSSAの外側ではtype 7は使用できないので、ABRがtype 7からtype 5への変換を行います。type 7からtype 5へ変換されたLSAは以下の通りです。

Advertising RouterがABR(R3)で、Forwarding AddressがASBR(R4)になっている事に注意して下さい。

Frame 52: 98 bytes on wire (784 bits), 98 bytes captured (784 bits)
Ethernet II, Src: cc:02:16:74:00:01 (cc:02:16:74:00:01), Dst: IPv4mcast_00:00:05 (01:00:5e:00:00:05)
Internet Protocol Version 4, Src: 192.168.23.3 (192.168.23.3), Dst: 224.0.0.5 (224.0.0.5)
Open Shortest Path First
    OSPF Header
    LS Update Packet
        Number of LSAs: 1
        LS Type: AS-External-LSA (ASBR)
            LS Age: 1 seconds
            Do Not Age: False
            Options: 0x20 (DC)
            Link-State Advertisement Type: AS-External-LSA (ASBR) (5)
            Link State ID: 192.168.4.0
            Advertising Router: 10.3.3.3 (10.3.3.3)
            LS Sequence Number: 0x80000001
            LS Checksum: 0x7b8e
            Length: 36
            Netmask: 255.255.255.0
            External Type: Type 2 (metric is larger than any other link state path)
            Metric: 20
            Forwarding Address: 10.4.4.4
            External Route Tag: 0

showコマンドによる確認

show ip ospf databaseで全LSAの概要を見る事ができます。

R2#show ip ospf database

            OSPF Router with ID (10.2.2.2) (Process ID 1)

                Router Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum Link count
10.2.2.2        10.2.2.2        55          0x80000002 0x00E9F6 2
10.3.3.3        10.3.3.3        56          0x80000002 0x00EEE5 2

                Net Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum
192.168.23.3    10.3.3.3        56          0x80000001 0x008CF3

                Summary Net Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum
10.4.4.4        10.3.3.3        52          0x80000001 0x0057B1
192.168.12.0    10.2.2.2        97          0x80000001 0x00337A
192.168.34.0    10.3.3.3        92          0x80000001 0x002B69

                Summary ASB Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum
10.1.1.1        10.2.2.2        56          0x80000001 0x00B75D

                Router Link States (Area 12)

Link ID         ADV Router      Age         Seq#       Checksum Link count
10.1.1.1        10.1.1.1        63          0x80000002 0x0065B9 1
10.2.2.2        10.2.2.2        62          0x80000002 0x003ADE 1

                Net Link States (Area 12)

Link ID         ADV Router      Age         Seq#       Checksum
192.168.12.2    10.2.2.2        62          0x80000001 0x00E2B2

                Summary Net Link States (Area 12)

Link ID         ADV Router      Age         Seq#       Checksum
10.2.2.2        10.2.2.2        97          0x80000001 0x004AD1
10.3.3.3        10.2.2.2        47          0x80000001 0x008D81
10.4.4.4        10.2.2.2        47          0x80000001 0x00D031
192.168.23.0    10.2.2.2        97          0x80000001 0x00B9E8
192.168.34.0    10.2.2.2        47          0x80000001 0x00A4E8

                Summary ASB Link States (Area 12)

Link ID         ADV Router      Age         Seq#       Checksum
10.3.3.3        10.2.2.2        47          0x80000001 0x007599

                Type-5 AS External Link States

Link ID         ADV Router      Age         Seq#       Checksum Tag
192.168.1.0     10.1.1.1        112         0x80000001 0x00BB6D 0
192.168.4.0     10.3.3.3        52          0x80000001 0x007B8E 0
R2#

以下のようにLSAのtypeを指定すると、より詳細な情報を見る事ができます。

R3#show ip ospf database asbr-summary 10.1.1.1

            OSPF Router with ID (10.3.3.3) (Process ID 1)

                Summary ASB Link States (Area 0)

  Routing Bit Set on this LSA
  LS age: 226
  Options: (No TOS-capability, DC, Upward)
  LS Type: Summary Links(AS Boundary Router)
  Link State ID: 10.1.1.1 (AS Boundary Router address)
  Advertising Router: 10.2.2.2
  LS Seq Number: 80000001
  Checksum: 0xB75D
  Length: 28
  Network Mask: /0
        TOS: 0  Metric: 10

R3#
R3#show ip ospf database external 192.168.1.0

            OSPF Router with ID (10.3.3.3) (Process ID 1)

                Type-5 AS External Link States

  Routing Bit Set on this LSA
  LS age: 308
  Options: (No TOS-capability, DC)
  LS Type: AS External Link
  Link State ID: 192.168.1.0 (External Network Number )
  Advertising Router: 10.1.1.1
  LS Seq Number: 80000001
  Checksum: 0xBB6D
  Length: 36
  Network Mask: /24
        Metric Type: 2 (Larger than any link state path)
        TOS: 0
        Metric: 20
        Forward Address: 0.0.0.0
        External Route Tag: 0

R3#
R3#show ip ospf database nssa-external 192.168.4.0

            OSPF Router with ID (10.3.3.3) (Process ID 1)

                Type-7 AS External Link States (Area 34)

  Routing Bit Set on this LSA
  LS age: 304
  Options: (No TOS-capability, Type 7/5 translation, DC)
  LS Type: AS External Link
  Link State ID: 192.168.4.0 (External Network Number )
  Advertising Router: 10.4.4.4
  LS Seq Number: 80000001
  Checksum: 0xD12B
  Length: 36
  Network Mask: /24
        Metric Type: 2 (Larger than any link state path)
        TOS: 0
        Metric: 20
        Forward Address: 10.4.4.4
        External Route Tag: 0

R3#
タイトルとURLをコピーしました