1. コマンド一覧

このシナリオで重要なコマンド一覧は以下の通りです。

Router(config)# ipv6 router rip
Router(config-GigaEthernetX.Y)# ip rip enable
Router(config-GigaEthernetX.Y)# ipv6 rip enable

2. 仕様説明

2.1. RIP

以下のコマンドでRIPv2を有効にする事ができます。 Cisco機と異なり、ルーティングプロセスではなくインターフェースに対して設定する事に注意して下さい。

Router(config-GigaEthernetX.Y)# ip rip enable

2.2. RIPng

RIPng (RIP next generation)はIPv6用のRIPです。 NEC IXルータではRIPngを使用するには、 "ipv6 router rip"コマンドでRIPngルーティングを開始する必要があります。

Router(config)# ipv6 router rip

RIPngを有効にしたいインターフェースに"ipv6 rip enable"コマンドを投入します。 Cisco機のようにRIPngプロセス名の指定はできません。

Router(config-GigaEthernetX.Y)# ipv6 rip enable

3. 動作確認環境

以下の構成で動作確認を行います。 GNS3のCiscoルータと実機のNEC IX2215を組み合わせて動作確認を行います。 実機エミュレータの混在環境構築手順についてはGNS3 実ネットワークとの接続設定を参照ください。

 [R1:Cisco]
interface Ethernet0/0
 ip address 192.168.0.1 255.255.255.0
 ipv6 address 2001::1/64
 ipv6 address FE80::1 link-local
interface Loopback0
 ip address 10.1.1.1 255.255.255.255
 ipv6 address 2001:1::1/128
 ipv6 address FE80::1 link-local

 [R2:Cisco]
interface Ethernet0/0
 ip address 192.168.0.2 255.255.255.0
 ipv6 address 2001::2/64
 ipv6 address FE80::2 link-local
interface Loopback0
 ip address 10.2.2.2 255.255.255.255
 ipv6 address 2001:2::2/128
 ipv6 address FE80::2 link-local

 [R254:IX2215]
interface GigaEthernet1.0
  ip address 192.168.0.254/24
  ipv6 address 2001::254/64
  no shutdown

初期設定の全文は以下を参照下さい。

4. RIP 基本的な設定例

4.1. Cisco機 設定投入

Cisco機にRIP, RIPngの設定を投入します。

 [R1, R2 : Cisco3640]
interface Ethernet0/0
 ipv6 rip RIPng enable
interface Loopback0
 ipv6 rip RIPng enable
!
router rip
 version 2
 network 10.0.0.0
 network 192.168.0.0
 no auto-summary

4.2. NEC機 RIP 設定投入

NECルータにRIPの設定を投入します。

 [R254:IX2215]
interface GigaEthernet1.0
  ip rip enable

4.3. NEC機 RIPng 設定投入

NECルータにRIPngの設定を投入します。 まず、"ipv6 router rip"のコマンドでRIPngルーティングを開始させる必要があります

 [R254:IX2215]
ipv6 router rip

RIPngを有効にしたいインターフェースに以下コマンドを投入します。

 [R254:IX2215]
interface GigaEthernet1.0
  ipv6 rip enable

4.4. RIP 設定確認

RIP interfaceが有効になっている事を確認します。 "show ip rip interface", "show ipv6 rip interface"コマンドを使用して下さい。

 [R254:IX2215]
R254(config)# show ip rip interface
Interface is GigaEthernet1.0
  RIP is enabled, 192.168.0.254, 2 neighbors, uptime 0:23:31
  Version control: send version 2, receive version 2
  Statistics:
    66 packets input, 0 bad packets
      0 bad port, 0 bad command, 0 bad version
      0 bad mustbezero, 0 bad length
      0 bad authentication, 0 bad metric
    64 routes receive, 0 bad routes
      0 bad mustbezero, 0 bad family, 0 bad nexthop
      0 bad address, 0 bad mask, 0 bad metric
    34 packets output, 61 routes advert, 3 triggered update
R254(config)#
R254(config)#
R254(config)# show ipv6 rip interface
Interface is GigaEthernet0.0
  RIPng is disabled, ::, 0 neighbors
Interface is GigaEthernet1.0
  RIPng is enabled, fe80::260:b9ff:fee2:a21d, 2 neighbors
  Version control: send version 1, receive version 1
  Statistics:
    46 packets input, 0 bad packets, 0 bad routes
    24 packets output
Interface is GigaEthernet2.0
  RIPng is disabled, ::, 0 neighbors
Interface is BRI0.0
  RIPng is disabled, ::, 0 neighbors
Interface is USB-Serial0.0
  RIPng is disabled, ::, 0 neighbors
Interface is Null0.0
  RIPng is disabled, ::, 0 neighbors
Interface is Loopback0.0
  RIPng is disabled, ::, 0 neighbors
R254(config)#

経路情報を交換できている事を確認します。

 [R254:IX2215]
R254(config)# show ip route rip
IP Routing Table - 2 entries, 3 hidden, 2043 frees
Entries: 0 Connected, 0 Static, 2 RIP, 0 OSPF, 0 BGP
Codes: C - Connected, S - Static, R - RIP, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, B - BGP
       * - Candidate default, s - Summary
Timers: Age
R      10.1.1.1/32 [120/2] via 192.168.0.1, GigaEthernet1.0, 0:00:28
R      10.2.2.2/32 [120/2] via 192.168.0.2, GigaEthernet1.0, 0:00:14
R254(config)#
R254(config)#
R254(config)# show ipv6 route rip
IPv6 Routing Table - 4 entries, unlimited
Codes: C - Connected, L - Local, S - Static
       R - RIPng, O - OSPF, IA - OSPF inter area
       E1 - OSPF external type 1, E2 - OSPF external type 2, B - BGP
       s - Summary
Timers: Uptime/Age
R      2001::/64 global [120/2]
         via fe80::2, GigaEthernet1.0, 0:14:51/0:00:02
         via fe80::1, GigaEthernet1.0, 0:14:28/0:00:10
R      2001:1::1/128 global [120/2]
         via fe80::1, GigaEthernet1.0, 0:14:28/0:00:10
R      2001:2::2/128 global [120/2]
         via fe80::2, GigaEthernet1.0, 0:00:55/0:00:02
R254(config)#

疎通確認は、NEC IX static routing 設定と同様の方法で可能です。 確認結果については省略します。

5. Tips

5.1. RIPngルーティングの開始

NECルータは、まず"ipv6 router rip"のコマンドでRIPngルーティングを開始させる必要があります。 Cisco機と異なるので注意が必要です。 もし、RIPngルーティングが開始されていない場合は、RIPngインターフェースの確認時に "RIPng is disabled"の文字列を確認できると思います。

R254(config)# show ipv6 rip interface
Interface is GigaEthernet0.0
  RIPng is disabled, ::, 0 neighbors
Interface is GigaEthernet1.0
  RIPng is disabled, fe80::260:b9ff:fee2:a21d, 0 neighbors
Interface is GigaEthernet2.0
  RIPng is disabled, ::, 0 neighbors
Interface is BRI0.0
  RIPng is disabled, ::, 0 neighbors
Interface is USB-Serial0.0
  RIPng is disabled, ::, 0 neighbors
Interface is Null0.0
  RIPng is disabled, ::, 0 neighbors
Interface is Loopback0.0
  RIPng is disabled, ::, 0 neighbors
R254(config)#