Cisco IOS フレームリレー – sub interfaceの複雑な設定例01

スポンサーリンク

複雑なframe relay subinterface設定例を紹介します。frame relayはNBMAである特殊な環境なので、OSPF network typeを適切に設定しないとルーティングが機能しません。

構成図

以下の環境で動作確認を行います。ルータFRSWをFrame Relay Switchとして代用しています。

 [pysical diagram]
           192.168.123.0/24
                             +------+
                     ┌------+  R2  |
       s0/0      s0/1│    .2+------+
 +------+  s0/0+-----+--+  s0/0
 |  R1  +------+  FRSW  |
 +------+      +-----+--+  s0/0
                 s0/2│    .3+------+
                     └------+  R3  |
                             +------+

 [logical diagram]
           192.168.123.0/24
                             +------+
         s0/0.2      ┌------+  R2  |
 +------+.102        │    .2+------+
 |      +------------┘    s0/0
 |  R1  |
 |      +------------┐    s0/0
 +------+.103        │    .3+------+
         s0/0.3      └------+  R3  |
                             +------+
 [R1, R2, R3]
interface Serial0/0
 encapsulation frame-relay

 [FRSW]
frame-relay switching
!
interface Serial0/0
 frame-relay intf-type dce
 frame-relay route 102 interface Serial0/1 201
 frame-relay route 103 interface Serial0/2 301
!
interface Serial0/1
 frame-relay intf-type dce
 frame-relay route 201 interface Serial0/0 102
!
interface Serial0/2
 frame-relay intf-type dce
 frame-relay route 301 interface Serial0/0 103

設定全文は下記ファイルです。詳細設定は下記を参照ください。

R1
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Serial0/0
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
!
interface Serial0/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
ip http server
ip forward-protocol nd
!
!
!
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
 login
!
!
end
R2
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Serial0/0
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
!
interface Serial0/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
ip http server
ip forward-protocol nd
!
!
!
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
 login
!
!
end
R3
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Serial0/0
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
!
interface Serial0/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
ip http server
ip forward-protocol nd
!
!
!
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
 login
!
!
end
FRSW
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname FRSW
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
!
!
frame-relay switching
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Serial0/0
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
 frame-relay intf-type dce
 frame-relay route 102 interface Serial0/1 201
 frame-relay route 103 interface Serial0/2 301
!
interface Serial0/1
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
 frame-relay intf-type dce
 frame-relay route 201 interface Serial0/0 102
!
interface Serial0/2
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
 frame-relay intf-type dce
 frame-relay route 301 interface Serial0/0 103
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
ip http server
ip forward-protocol nd
!
!
!
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
 login
!
!
end

Frame Relay

設定投入

通常、Cisco IOSは同一セグメントのIPアドレスを複数のinterfaceに設定する事ができません。しかし、frame relayのsubinterfaceは例外で、同一セグメントのIPアドレスを複数のinterfaceに設定できます。この仕様を利用すると、Hub Routerにおいて、Spoke毎に異なる送信元IPアドレスを設定する事ができます。

 [R1]
interface Serial0/0.2 point-to-point
 ip address 192.168.123.102 255.255.255.0
 frame-relay interface-dlci 102
!
interface Serial0/0.3 point-to-point
 ip address 192.168.123.103 255.255.255.0
 frame-relay interface-dlci 103

 [R2]
interface Serial0/0
 ip address 192.168.123.2 255.255.255.0
 encapsulation frame-relay
 frame-relay map ip 192.168.123.102 201 broadcast
 frame-relay map ip 192.168.123.2 201

 [R3]
interface Serial0/0
 ip address 192.168.123.3 255.255.255.0
 serial restart-delay 0
 frame-relay map ip 192.168.123.103 301 broadcast
 frame-relay map ip 192.168.123.3 301

動作確認

この時点ではpingによる疎通はできない状態ですが、心配ございません。後述のOSPFを投入する事で疎通可能になります。

 [R1]
R1#ping 192.168.123.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.123.2, timeout is 2 seconds:
...
Success rate is 0 percent (0/3)
R1#

OSPF

設定投入

ルータ間でOSPFを設定します。このようなhub and spoke構成の場合は、network typeとしてpoint-to-multipointを使用します。

 [R1]
interface Serial0/0.2 point-to-point
 ip ospf network point-to-multipoint
!
interface Serial0/0.2 point-to-point
 ip ospf network point-to-multipoint
!
router ospf 1
 network 0.0.0.0 255.255.255.255 area 0

 [R2, R3]
interface Serial0/0
 ip ospf network point-to-multipoint
!
router ospf 1
 network 0.0.0.0 255.255.255.255 area 0

動作確認

ルータ間で疎通可能になった事を確認します。

 [R1]
R1#ping 192.168.123.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.123.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 56/80/112 ms
R1#ping 192.168.123.102

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.123.102, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 108/136/168 ms
R1#

 [R2]
R2#ping 192.168.123.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.123.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 72/140/256 ms
R2#ping 192.168.123.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.123.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 108/164/264 ms
R2#
タイトルとURLをコピーしました