Cisco IOS QoS – Link Fragmentation and Interleaving (LFI)の設定

スポンサーリンク

低帯域環境でデータサイズが大きいパケットが流れると、音声パケットは待ち状態になり音声品質が劣化します。大きなパケットを分割(fragment)し、分割された間に小さな音声パケットを割り込ませる(interleave)事で品質を向上させます。

Frame Relay Fragmentation

基本設定

frame relayを設定する方法はinterface全体に対して設定する方法とframe relay traffic shaping(map-classコマンド)を使用する方法の2通りがあります。

interface全体に対して設定する方法は以下の通りです。

Router(config-if)# frame-relay fragment <byte> end-to-end

frame relay traffic shaping(map-classコマンド)を使うためには、まず以下のようなmap-classを定義します。

Router(config)#map-class frame-relay <map_class&t;
Router(config-map-class)# frame-relay <byte&t;

map-classは以下のコマンドで、interface全体かDLCIに適用する事ができます。

Router(config-if)#frame-relay class <map_class&t;

Router(config-if)# frame-relay interface-dlci <dlci&t;
Router(config-fr-dlci)# class <map_class&t;

frame relay traffic shaping(map-classコマンド)を有効にするためには、frame-relay traffic-shapingコマンドを入力して下さい。

Router(config-if)# frame-relay traffic-shaping

動作確認

以下の構成で、R1, R2間でframe relay fragmentationを実装します。

                             s0/1      s0/1
 +--------+          +--------+          +--------+          +--------+
 |        |          |        +----------+        |          |        |
 |   R1   |          |   R2   |          |   R3   |          |   R4   |
 |        +----------+        +----------+        +----------+        |
 +--------+.1      .2+--------+.2      .3+--------+.3      .4+--------+
         s0/0      s0/0      s0/2      s0/2      s0/3      s0/3
         192.168.12.0/24     192.168.23.0/24     192.168.34.0/24
 [R1]
interface Serial0/0
 ip address 192.168.12.1 255.255.255.0
 encapsulation frame-relay
 no keepalive
 clock rate 128000
 frame-relay fragment 160 end-to-end
 frame-relay map ip 192.168.12.2 100 broadcast

 [R2]
interface Serial0/0
 ip address 192.168.12.2 255.255.255.0
 encapsulation frame-relay
 no keepalive
 frame-relay traffic-shaping
 frame-relay map ip 192.168.12.2 100 broadcast
 frame-relay interface-dlci 100
  class DLCI100
!
map-class frame-relay DLCI100
 frame-relay fragment 160

show frame-relay fragmentでfragment sizeを確認する事ができます。なお、frame-relay traffic-shapingを忘れた場合は、このshowコマンドに対して何も表示されないようになります。

R2#show frame-relay fragment
interface                dlci frag-type  size in-frag    out-frag   dropped-frag
Se0/0                    100  end-to-end 160  100        100        0
R2#

MLPPP LFI

基本設定

Link Fragmentation and Interleaving(LFI)は、大きなサイズのパケットをfragmentし、その間にvoiceなどの小さなパケットを滑り込ませる事で、シリアル化遅延による揺らぎを軽減する技術です。

LFIが設定可能なのはMulti Link PPP(MLPPP)に対してのみで、PPP linkに対して設定する事はできません。そのため、LFIを使用したい時は、仮にlinkが1本しかなかったとしてもMLPPPを設定しなければなりません。

MLPPPの設定方法は以下の通りです。以下のようにmultilink groupという番号を用いて、物理interfaceとmultilink interfaceの紐付けを行います。

Router(config)# interface Serial0/1
Router(config-if)# ppp multilink group 1

Router(config)# interface Serial0/2
Router(config-if)# ppp multilink group 1

Router(config)# interface Multilink1
Router(config-if)# ppp multilink group 1

FragmentationとInterleaveの設定は以下の通りです。Fragmentationはdelayで遅延時間を指定する事ができます。

Router(config)# interface Multilink1
Router(config-if)# ppp multilink fragment delay <milisec>
Router(config-if)# ppp multilink interleave

動作確認

以下の構成で、R2, R3間でMulti Link PPP(MLPPP)を作成し、MLPPPに対してLink Fragmentation Interleave(LFI)を有効にします。

                             s0/1      s0/1
 +--------+          +--------+          +--------+          +--------+
 |        |          |        +----------+        |          |        |
 |   R1   |          |   R2   |          |   R3   |          |   R4   |
 |        +----------+        +----------+        +----------+        |
 +--------+.1      .2+--------+.2      .3+--------+.3      .4+--------+
         s0/0      s0/0      s0/2      s0/2      s0/3      s0/3
         192.168.12.0/24     192.168.23.0/24     192.168.34.0/24
 [R2]
interface Serial0/1
 encapsulation ppp
 ppp multilink group 1

interface Serial0/2
 encapsulation ppp
 ppp multilink group 1

interface Multilink1
 ip address 192.168.23.2 255.255.255.0
 ppp multilink fragment delay 10
 ppp multilink interleave
 ppp multilink group 1

 [R2]
interface Serial0/1
 encapsulation ppp
 ppp multilink group 1

interface Serial0/2
 encapsulation ppp
 ppp multilink group 1

interface Multilink1
 ip address 192.168.23.3 255.255.255.0
 ppp multilink fragment delay 10
 ppp multilink interleave
 ppp multilink group 1

CCIE R&S Lab試験では、show runを読むのが一番現実的な確認方法かと思われます。

MLPPP LFI over Frame Relay

動作確認

以下の構成で、R3, R4間のFrame RelayでLink Fragmentation Interleave(LFI)を有効にします。

Frame RelayでLFIを実装するには、かなり複雑なconfigが必要です。なぜなら、Frame Relay Interfaceに対してInterleaveの設定ができないからです。もし、Frame Relay網でInterleaveを実装したいならば、PPP over Frame Relayを実装し、そのPPPに対しFLIを適用します。

                             s0/1      s0/1
 +--------+          +--------+          +--------+          +--------+
 |        |          |        +----------+        |          |        |
 |   R1   |          |   R2   |          |   R3   |          |   R4   |
 |        +----------+        +----------+        +----------+        |
 +--------+.1      .2+--------+.2      .3+--------+.3      .4+--------+
         s0/0      s0/0      s0/2      s0/2      s0/3      s0/3
         192.168.12.0/24     192.168.23.0/24     192.168.34.0/24
 [R3]
interface Serial0/3
 encapsulation frame-relay
 no keepalive
 frame-relay interface-dlci 100 ppp Virtual-Template2

interface Virtual-Template2
 ip address 192.168.34.3 255.255.255.0
 ppp multilink fragment delay 10
 ppp multilink interleave

 [R4]
interface Serial0/3
 encapsulation frame-relay
 no keepalive
 frame-relay interface-dlci 100 ppp Virtual-Template2

interface Virtual-Template2
 ip address 192.168.34.4 255.255.255.0
 ppp multilink fragment delay 10
 ppp multilink interleave

以上の設定の最終的なconfigは以下の通りになります。

R1
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 10.1.1.1 255.255.255.255
!
interface Serial0/0
 ip address 192.168.12.1 255.255.255.0
 encapsulation frame-relay
 no keepalive
 serial restart-delay 0
 clock rate 128000
 frame-relay fragment 160 end-to-end
 frame-relay map ip 192.168.12.2 100 broadcast
!
interface Serial0/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
router eigrp 10
 network 0.0.0.0
 no auto-summary
!
ip http server
ip forward-protocol nd
!
!
!
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
 login
!
!
end
R2
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 10.2.2.2 255.255.255.255
!
interface Multilink1
 ip address 192.168.23.2 255.255.255.0
 ppp multilink
 ppp multilink fragment delay 10
 ppp multilink interleave
 ppp multilink group 1
!
interface Serial0/0
 ip address 192.168.12.2 255.255.255.0
 encapsulation frame-relay
 no ip route-cache cef
 no ip route-cache
 no keepalive
 serial restart-delay 0
 frame-relay traffic-shaping
 frame-relay map ip 192.168.12.2 100 broadcast
 frame-relay interface-dlci 100
  class DLCI100
!
interface Serial0/1
 no ip address
 encapsulation ppp
 serial restart-delay 0
 ppp multilink
 ppp multilink group 1
!
interface Serial0/2
 no ip address
 encapsulation ppp
 serial restart-delay 0
 ppp multilink
 ppp multilink group 1
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
router eigrp 10
 network 0.0.0.0
 no auto-summary
!
ip http server
ip forward-protocol nd
!
!
!
!
map-class frame-relay DLCI100
 frame-relay fair-queue
 frame-relay fragment 160
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
 login
!
!
end
R3
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 10.3.3.3 255.255.255.255
!
interface Multilink1
 ip address 192.168.23.3 255.255.255.0
 ppp multilink
 ppp multilink fragment delay 10
 ppp multilink interleave
 ppp multilink group 1
!
interface Serial0/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/1
 no ip address
 encapsulation ppp
 serial restart-delay 0
 ppp multilink
 ppp multilink group 1
!
interface Serial0/2
 no ip address
 encapsulation ppp
 serial restart-delay 0
 ppp multilink
 ppp multilink group 1
!
interface Serial0/3
 no ip address
 encapsulation frame-relay
 no keepalive
 serial restart-delay 0
 frame-relay interface-dlci 100 ppp Virtual-Template2
!
interface Virtual-Template1
 no ip address
!
interface Virtual-Template2
 ip address 192.168.34.3 255.255.255.0
 ppp multilink fragment delay 10
 ppp multilink interleave
!
!
router eigrp 10
 network 0.0.0.0
 no auto-summary
!
ip http server
ip forward-protocol nd
!
!
!
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
 login
!
!
end
R4
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R4
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 10.4.4.4 255.255.255.255
!
interface Serial0/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 encapsulation frame-relay
 no keepalive
 serial restart-delay 0
 frame-relay interface-dlci 100 ppp Virtual-Template2
!
interface Virtual-Template2
 ip address 192.168.34.4 255.255.255.0
 ppp multilink fragment delay 10
 ppp multilink interleave
!
!
router eigrp 10
 network 0.0.0.0
 no auto-summary
!
ip http server
ip forward-protocol nd
!
!
!
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
 login
!
!
end
タイトルとURLをコピーしました