1. コマンド一覧

このシナリオで重要なコマンド一覧は以下の通りです。

Router(config)# interface GigaEthernet0.X
Router(config-GigaEthernet0.X)# encapsulation dot1q <vlan_id>
Router(config-GigaEthernet0.X)# ip address <addr>/<mask>
Router(config-GigaEthernet0.X)# ipv6 address <addr>/<mask>
Router(config-GigaEthernet0.X)# no shutdown

Router(config)# device GigaEthernet2
Router(config-GigaEthernet2)# vlan-group <group_num> port <port_num> [  <port_num> ... ]
Router(config)# interface GigaEthernet2:X.Y
Router(config-GigaEthernet2:X.Y)# encapsulation dot1q <vlan_id>
Router(config-GigaEthernet2:X.Y)# ip address <addr>/<mask>
Router(config-GigaEthernet2:X.Y)# ipv6 address <addr>/<mask>
Router(config-GigaEthernet2:X.Y)# no shutdown

2. 仕様説明

2.1. インターフェースの指定

以下のようなコマンドを用いて、インターフェースコンフィグモードに入ります。 Xはデバイス番号を表しています。

Router(config)# interface GigaEthernetX.0
Router(config-GigaEthernetX.0)# 

2.2. IPアドレスの設定

以下のようなコマンドを用いて、IPv4アドレス, IPv6アドレスを設定する事ができます。 なお、現時点(2014/02/06)のIXルータはIPv6リンクローカルアドレスを明示指定する事はできないようです。

Router(config)# interface GigaEthernetX.0
Router(config-GigaEthernetX.0)# ip address <addr>/<mask>
Router(config-GigaEthernetX.0)# ipv6 address <addr>/<mask>

2.3. インターフェースの有効化

デフォルトは"administratively down"状態ですので 通信をするには"no shut"コマンドが必要になります。

Router(config)# interface GigaEthernetX.0
Router(config-GigaEthernetX.0)# no shutdown

3. 動作確認環境

以下の構成で動作確認を行います。


            ::100    ::254           .254     ::200
 +---------+ .100     .254 +--------+.254      .200 +---------+
 | Host100 +---------------+ IX2215 +---------------+ Host200 |
 +---------+          G1.0 +--------+ G0.0          +---------+
            192.168.0.0/24           150.0.0.0/24
            2001::/64                2001:150::/64

IX2215は工場出荷時の初期設定の状態で検証を開始します。

4. 設定投入

以下のようなコマンドを用いて、IPv4アドレス、IPv6アドレスを設定します。

interface GigaEthernet1.0
  ip address 192.168.0.254/24
  ipv6 address 2001::254/64
  no shutdown
!
interface GigaEthernet0.0
  ip address 150.0.0.254/24
  ipv6 address 2001:150::254/64
  no shutdown

5. 設定確認

interfaceのup/downを確認するには、"show interface brief"が便利です。

Router# show interfaces brief
Interface GigaEthernet0.0 is up
  IPv4 subsystem connected, physical layer is up, 0:06:44
  ARP subsystem connected, physical layer is up, 0:06:44
  IPv6 subsystem connected, physical layer is up, 0:06:44
Interface GigaEthernet0.1 is administratively down
Interface GigaEthernet1.0 is up
  IPv4 subsystem connected, physical layer is up, 1:27:35
  ARP subsystem connected, physical layer is up, 1:27:35
  IPv6 subsystem connected, physical layer is up, 1:27:35
Interface GigaEthernet2.0 is administratively down
Interface GigaEthernet2.1 is administratively down
Interface BRI0.0 is administratively down
Interface USB-Serial0.0 is administratively down
Interface Null0.0 is up
  IPv4 subsystem connected, physical layer is up, 2:37:03
  IPv6 subsystem connected, physical layer is up, 2:37:03
Interface Loopback0.0 is up
  IPv6 subsystem connected, physical layer is up, 2:37:03
Router#

IPv4アドレス IPv6アドレスを確認するには、"show ip interface", "show ipv6 interface"を使って下さい。 cisco機のように"show ip int bri"や"| include"は使えないので、かなり読みづらいです。

Router# show ip interface GigaEthernet1.0
Interface GigaEthernet1.0 is up, line protocol is up
  Internet address is 192.168.0.254/24
  Broadcast address is 255.255.255.255
  Address determined by config
  MTU is 1500 octets
  Directed broadcast forwarding is disabled
  Proxy ARP is disabled
  Local proxy ARP is disabled
  ICMP redirects are always sent
  IGMP is disabled
  TCP MSS adjustment is disabled
Router#
Router#
Router#
Router# show ipv6 interface GigaEthernet1.0
Interface GigaEthernet1.0 is up, line protocol is up
  Interface identifier is 0260:b9ff:fee2:a21d
  MTU is 1500 octets, Hop-limit is 64
  ICMP redirects are always sent
  TCP MSS adjustment is disabled
  Global address(es):
    2001::254 prefixlen 64
    2001:: prefixlen 64 anycast
  Link-local address(es):
    fe80::260:b9ff:fee2:a21d prefixlen 64
    fe80:: prefixlen 64 anycast
  Multicast address(es):
    ff02::1
    ff02::2
    ff02::1:ff00:0
    ff02::1:ff00:254
    ff02::1:ffe2:a21d
  Advertising prefix is auto-prefix11:
    2001:: prefixlen 64
    Valid life time 2592000 seconds
    Preferred life time 604800 seconds
    On-link flag is on
    Autonomous flag is on
  Neighbor discovery variable(s):
    Neighbor cache garbage time 0 seconds
  Router advertisement variable(s):
    Sending RA is disabled
    Max transmit interval 600 seconds
    Min transmit interval 198 seconds
    Reachable time 0 seconds
    Life time 1800 seconds
    Retrans timer 0 milliseconds
    Current hop limit 64 hops
    Managed address configuration flag is off
    Other stateful configuration flag is off
    Source link-layer address 00:60:b9:e2:a2:1d
    Prefix is auto-prefix11 address 2001:: prefixlen 64
  Neighbor solicitation variable(s):
    Transmit interval 0 seconds
  Stateless address auto configuration variable(s):
    DAD attempts 1, fails 0
  Multicast listener discovery variable(s):
    Running version is 2
    Query interval is 125 seconds
    Query max response delay is 10 seconds
    Robustness is 2
    Multicast listener interval is 260 seconds
    Other querier present interval is 255 seconds
    Startup query interval is 31 seconds
    Startup query count is 2
    Last listener query interval is 1 seconds
    Last listener query count is 2
    Last listener query time is 2 seconds
    Unsolicited report interval (version 1) is 10 seconds
    Unsolicited report interval (version 2) is 1 seconds
    Older version querier present interval is 260 seconds
    Older version host present interval is 260 seconds
    Querier is unknown
Router#

6. 疎通確認

Host100からIX2215への疎通を確認します。

C:\Users\host100>ping 192.168.0.254

192.168.0.254 に ping を送信しています 32 バイトのデータ:
192.168.0.254 からの応答: バイト数 =32 時間 <1ms TTL=64
192.168.0.254 からの応答: バイト数 =32 時間 <1ms TTL=64
192.168.0.254 からの応答: バイト数 =32 時間 <1ms TTL=64

192.168.0.254 の ping 統計:
    パケット数: 送信 = 3、受信 = 3、損失 = 0 (0% の損失)、
ラウンド トリップの概算時間 (ミリ秒):
    最小 = 0ms、最大 = 0ms、平均 = 0ms
Ctrl+C
^C
C:\Users\host100>
C:\Users\host100>
C:\Users\host100>ping 2001::254

2001::254 に ping を送信しています 32 バイトのデータ:
2001::254 からの応答: 時間 <1ms
2001::254 からの応答: 時間 <1ms
2001::254 からの応答: 時間 <1ms

2001::254 の ping 統計:
    パケット数: 送信 = 3、受信 = 3、損失 = 0 (0% の損失)、
ラウンド トリップの概算時間 (ミリ秒):
    最小 = 0ms、最大 = 0ms、平均 = 0ms
Ctrl+C
^C
C:\Users\host100>