1. コマンド一覧

このシナリオで重要なコマンド一覧は以下の通りです。

Router(config)# interface GigaEthernet0.X
Router(config-GigaEthernet0.X)# encapsulation dot1q <vlan_id>
Router(config-GigaEthernet0.X)# ip address <addr>/<mask>
Router(config-GigaEthernet0.X)# no shutdown

Router(config)# device GigaEthernet2
Router(config-GigaEthernet2)# vlan-group <group_num> port <port_num> [  <port_num> ... ]
Router(config)# interface GigaEthernet2:X.Y
Router(config-GigaEthernet2:X.Y)# encapsulation dot1q <vlan_id>
Router(config-GigaEthernet2:X.Y)# ip address <addr>/<mask>
Router(config-GigaEthernet2:X.Y)# no shutdown

2. 仕様説明

2.1. サブインターフェースの作成

VLANを設定するためのサブインターフェースを作成します。 作成したサブインターフェースに対してvlan IDを紐付ける事によって、 VLANタグ付きのフレームを送信する事ができます。 Cisco機で言う、"Router on a Stick", "trunk"に相当する概念になります。

サブインターフェース番号は、1から8までを使用する事ができます。 Cisco機のようにvlan idとサブインターフェース番号を一致させる命名規則が採用できないので 管理上の注意が必要になると思います。 また、vlan ID紐付けの設定反映には再起動が必要である事に注意して下さい。

Router(config)# interface GigaEthernet0.X
Router(config-GigaEthernet0.X)# encapsulation dot1q <vlan_id>
% You must restart the router for this configuration to take effect.
Router(config-GigaEthernet0.X)#

2.2. サブインターフェースの設定

以下のようなコマンドでサブインターフェースにIPアドレスを設定する事ができます。 また、デフォルトは"administratively down"状態ですので "no shut"コマンドを投入する必要がある事も留意して下さい。

Router(config)# interface GigaEthernet0.X
Router(config-GigaEthernet0.X)# ip address <addr>/<mask>
Router(config-GigaEthernet0.X)# no shutdown

2.3. サブインターフェースの作成 - ポートVLANと併用する場合

タグVLANとポートVLANを併用するのは若干複雑です。 まず、以下のようなコマンドでvlan-groupとportの紐付を行います。

Router(config)# device GigaEthernet2
Router(config-GigaEthernet2)# vlan-group <group_num> port <port_num> [  <port_num> ... ]

以下のようなコマンドでサブインターフェースを作成し、 作成したサブインターフェースに対してvlan IDを紐付けます。 例えば、device 2、vlan-group 3、サブインターフェース番号4に対するサブインターフェースを作成したい場合は、 GigaEthernet2:3.4のように指定します。

Router(config)# interface GigaEthernet2:X.Y
Router(config-GigaEthernet2:X.Y)# encapsulation dot1q <vlan_id>
% You must restart the router for this configuration to take effect.
Router(config-GigaEthernet2:X.Y)# 

2.4. サブインターフェースの設定 - ポートVLANと併用する場合

以下のようなコマンドでサブインターフェースにIPアドレスを設定する事ができます。 また、デフォルトは"administratively down"状態ですので "no shut"コマンドを投入する必要がある事も留意して下さい。

Router(config)# interface GigaEthernet2:X.Y
Router(config-GigaEthernet2:X.Y)# ip address <addr>/<mask>
Router(config-GigaEthernet2:X.Y)# no shutdown

3. 動作確認環境

IX2215とcatalyst2960Sを用いて動作確認を行います。


 +--------+ device0                  G0/1 +-------+
 |        +-------------------------------+       |
 |        | device2 port1            G0/2 |       |
 | IX2215 +-------------------------------+ 2960S |
 |        | device2 port4            G0/3 |       |
 |        +-------------------------------+       |
 +--------+                               +-------+
 vlan1 192.168.1.1/24                Vlan1 192.168.1.254/24
 vlan2 192.168.2.1/24                Vlan2 192.168.2.254/24
 vlan3 192.168.3.1/24                Vlan3 192.168.3.254/24
 vlan10 192.168.10.1/24              Vlan10 192.168.10.254/24
 vlan20 192.168.20.1/24              Vlan20 192.168.20.254/24
 vlan30 192.168.30.1/24              Vlan30 192.168.30.254/24
 vlan40 192.168.40.1/24              Vlan40 192.168.40.254/24

 [2960S]
interface Vlan1
 ip address 192.168.1.254 255.255.255.0
interface Vlan2
 ip address 192.168.2.254 255.255.255.0
interface Vlan3
 ip address 192.168.3.254 255.255.255.0
interface Vlan10
 ip address 192.168.10.254 255.255.255.0
interface Vlan20
 ip address 192.168.20.254 255.255.255.0
interface Vlan30
 ip address 192.168.30.254 255.255.255.0
interface Vlan40
 ip address 192.168.30.254 255.255.255.0
!
interface GigabitEthernet0/1
 switchport trunk allowed vlan 1-3
 switchport mode trunk
 spanning-tree portfast trunk
interface GigabitEthernet0/2
 switchport trunk native vlan 10
 switchport trunk allowed vlan 10,20
 switchport mode trunk
 spanning-tree portfast trunk
interface GigabitEthernet0/3
 switchport trunk native vlan 30
 switchport trunk allowed vlan 30,40
 switchport mode trunk
 spanning-tree portfast trunk

catalyst2960Sの初期設定は以下の通りです。 IX2215については工場出荷時の設定で検証を行います。

全ての設定が終わった時点の構成図をデフォルメして書くと以下のようになります。

4. 独立ポートのタグVLAN設定

4.1. サブインターフェース vlan設定

サブインターフェースとvlanを紐付る設定を投入します。

interface GigaEthernet0.2
 encapsulation dot1q 2
!
interface GigaEthernet0.3
 encapsulation dot1q 3

設定を反映させるために再起動させます。

Router(config)# reload
Notice: The router will be RELOADED. This is to ensure that
        the peripheral devices are properly initialized.
Are you sure you want to reload the router? (Yes or [No]): Yes

4.2. IPアドレスの付与

サブインターフェースにIPアドレスを付与します。

interface GigaEthernet0.0
 ip address 192.168.1.1/24
 no shutdown
!
interface GigaEthernet0.2
 ip address 192.168.2.1/24
 no shutdown
!
interface GigaEthernet0.3
 ip address 192.168.3.1/24
 no shutdown

4.3. 疎通確認

各VLANを経由した通信が可能である事を確認します。

Router(config)# ping 192.168.2.254
PING 192.168.2.1 > 192.168.2.254 56 data bytes
64 bytes from 192.168.2.254: icmp_seq=1 ttl=255 time=0.492 ms
64 bytes from 192.168.2.254: icmp_seq=2 ttl=255 time=0.466 ms
64 bytes from 192.168.2.254: icmp_seq=3 ttl=255 time=0.474 ms

--- 192.168.2.254 ping statistics ---
4 packets transmitted, 3 packets received, 25% packet loss
round-trip (ms)  min/avg/max = 0.466/0.477/0.492
Router(config)#
Router(config)#
Router(config)#
Router(config)#
Router(config)# ping 192.168.3.254
PING 192.168.3.1 > 192.168.3.254 56 data bytes
64 bytes from 192.168.3.254: icmp_seq=1 ttl=255 time=0.479 ms
64 bytes from 192.168.3.254: icmp_seq=2 ttl=255 time=0.474 ms
64 bytes from 192.168.3.254: icmp_seq=3 ttl=255 time=0.470 ms

--- 192.168.3.254 ping statistics ---
4 packets transmitted, 3 packets received, 25% packet loss
round-trip (ms)  min/avg/max = 0.470/0.474/0.479
Router(config)#

5. スイッチングハブのタグVLAN設定 - ポートVLANと併用しない場合

5.1. サブインターフェース vlan設定

サブインターフェースとvlanを紐付る設定を投入します。

interface GigaEthernet2.2
 encapsulation dot1q 20

設定を反映させるために再起動させます。

Router(config)# reload
Notice: The router will be RELOADED. This is to ensure that
        the peripheral devices are properly initialized.
Are you sure you want to reload the router? (Yes or [No]): Yes

5.2. IPアドレスの付与

サブインターフェースにIPアドレスを付与します。

interface GigaEthernet2.0
 ip address 192.168.10.1/24
!
interface GigaEthernet2.2
 ip address 192.168.20.1/24
 no shutdown

5.3. 疎通確認

各VLANを経由した通信が可能である事を確認します。

Router(config)# ping 192.168.10.254
PING 192.168.10.1 > 192.168.10.254 56 data bytes
64 bytes from 192.168.10.254: icmp_seq=0 ttl=255 time=2.003 ms
64 bytes from 192.168.10.254: icmp_seq=1 ttl=255 time=1.864 ms
64 bytes from 192.168.10.254: icmp_seq=2 ttl=255 time=1.826 ms

--- 192.168.10.254 ping statistics ---
3 packets transmitted, 3 packets received, 0% packet loss
round-trip (ms)  min/avg/max = 1.826/1.897/2.003
Router(config)#
Router(config)#
Router(config)#
Router(config)# ping 192.168.20.254
PING 192.168.20.1 > 192.168.20.254 56 data bytes
64 bytes from 192.168.20.254: icmp_seq=0 ttl=255 time=3.356 ms
64 bytes from 192.168.20.254: icmp_seq=1 ttl=255 time=1.704 ms
64 bytes from 192.168.20.254: icmp_seq=2 ttl=255 time=1.457 ms

--- 192.168.20.254 ping statistics ---
3 packets transmitted, 3 packets received, 0% packet loss
round-trip (ms)  min/avg/max = 1.457/2.172/3.356
Router(config)#

6. スイッチングハブのタグVLAN設定 - ポートVLANと併用する場合

6.1. サブインターフェース vlan設定

vlan-groupとportの紐付けを設定します。

device GigaEthernet2
 vlan-group 1 port 4 5 6

サブインターフェースとvlanを紐付る設定を投入します。

interface GigaEthernet2:1.4
 encapsulation dot1q 40

設定を反映させるために再起動させます。

Router(config)# reload
Notice: The router will be RELOADED. This is to ensure that
        the peripheral devices are properly initialized.
Are you sure you want to reload the router? (Yes or [No]): Yes

6.2. IPアドレスの付与

サブインターフェースにIPアドレスを付与します。

interface GigaEthernet2:1.0
 ip address 192.168.30.1/24
 no shutdown
!
interface GigaEthernet2:1.4
 ip address 192.168.40.1/24
 no shutdown

6.3. 疎通確認

各VLANを経由した通信が可能である事を確認します。

Router(config)# ping 192.168.30.254
PING 192.168.30.1 > 192.168.30.254 56 data bytes
64 bytes from 192.168.30.254: icmp_seq=0 ttl=255 time=0.845 ms
64 bytes from 192.168.30.254: icmp_seq=1 ttl=255 time=0.803 ms
64 bytes from 192.168.30.254: icmp_seq=2 ttl=255 time=0.502 ms

--- 192.168.30.254 ping statistics ---
3 packets transmitted, 3 packets received, 0% packet loss
round-trip (ms)  min/avg/max = 0.502/0.716/0.845
Router(config)#
Router(config)#
Router(config)# ping 192.168.40.254
PING 192.168.40.1 > 192.168.40.254 56 data bytes
64 bytes from 192.168.40.254: icmp_seq=0 ttl=255 time=3.356 ms
64 bytes from 192.168.40.254: icmp_seq=1 ttl=255 time=1.704 ms
64 bytes from 192.168.40.254: icmp_seq=2 ttl=255 time=1.457 ms

--- 192.168.40.254 ping statistics ---
3 packets transmitted, 3 packets received, 0% packet loss
round-trip (ms)  min/avg/max = 1.457/2.172/3.356
Router(config)#