Cisco IOS フレームリレー – 基本設定

スポンサーリンク

Frame Relayの基本的な設定方法について説明します。1通りのphysical interfaceを使う方法と2通りのlogical interfaceを使う方法があります。

概要

frame relayの基本的な設定方法をまとめます。

なお、frame relayは、sub interfaceを使って定義する事もできます。sub interfaceを使用する事で、1つの物理interfaceに対して複数のIPアドレスを定義する事ができます。設定方法は以下3通りになります。

  • main interface
  • point-to-point sub interface
  • multipoint sub interface

main interface

設定方法

必須設定はencapsulationとIPアドレスのみです。

Router(config)# interface <interface>
Router(config-if)# encapsulation frame-relay
Router(config-if)# ip address <addr> <mask>
Router(config-if)# no shutdown

inverse arpによってDLCI, IPアドレスの紐づけを自動的に行う事ができますが、以下のコマンドにより手動で紐づけを定義する事もできます。

Router(config-if)# frame-relay map ip <dlci> <addr> [ broadcast ]

動作確認

以下の環境で動作確認を行います。R1をハブとして、R2, R3をスポークとして設定します。

           192.168.123.0/24
                             +------+
                     ┌------+  R2  |
          s0/0      2│    .2+------+
 +------+.1   1+-----+--+  s0/0
 |  R1  +------+  FRSW | 
 +------+      +-----+--+  s0/0
                    3│    .3+------+
                     └------+  R3  |
                             +------+
             1:102 = 2:201
             1:103 = 3:301
 [R1]
interface Serial0/0
 ip address 192.168.123.1 255.255.255.0
 encapsulation frame-relay

 [R2]
interface Serial0/0
 ip address 192.168.123.2 255.255.255.0
 encapsulation frame-relay

 [R3]
interface Serial0/0
 ip address 192.168.123.3 255.255.255.0
 encapsulation frame-relay

動作確認

しばらく待つと、inverse-arpにより自動的にDLCI, IPアドレスの紐づけが定義されます。紐づけを確認するには、以下のコマンドを入力して下さい。

 [R1]
R1#show frame-relay map
Serial0/0 (up): ip 192.168.123.2 dlci 102(0x66,0x1860), dynamic,
              broadcast,
              CISCO, status defined, active
Serial0/0 (up): ip 192.168.123.3 dlci 103(0x67,0x1870), dynamic,
              broadcast,
              CISCO, status defined, active
R1#

 [R2]
R2#show frame-relay map
Serial0/0 (up): ip 192.168.123.1 dlci 201(0xC9,0x3090), dynamic,
              broadcast,
              CISCO, status defined, active
R2#

 [R3]
R3#show frame-relay map
Serial0/0 (up): ip 192.168.123.1 dlci 301(0x12D,0x48D0), dynamic,
              broadcast,
              CISCO, status defined, active
R3#

R1からR2, R3へ疎通可能である事を確認します。(なお、現時点ではR2, R3間の疎通はできません)

R1#ping 192.168.123.255

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.123.255, timeout is 2 seconds:

Reply to request 0 from 192.168.123.3, 96 ms
Reply to request 0 from 192.168.123.2, 100 ms

static mapの定義

上記の設定のみでは、R2, R3間で疎通できません。R2, R3間で疎通可能にするには、以下のようにstaticに紐づけを定義します。(疎通不能である理由は、inverse arpの仕組みを考えれば分かります。inverse arpについては別の機会で触れます。)

 [R1]
interface Serial0/0
 ip address 192.168.123.1 255.255.255.0
 encapsulation frame-relay

 [R2]
interface Serial0/0
 ip address 192.168.123.2 255.255.255.0
 encapsulation frame-relay
 frame-relay map ip 192.168.123.3 201 broadcast

 [R3]
interface Serial0/0
 ip address 192.168.123.3 255.255.255.0
 encapsulation frame-relay
 frame-relay map ip 192.168.123.2 301 broadcast

R2, R3間で疎通可能である事を確認します。

R3#show frame-relay map
Serial0/0 (up): ip 192.168.123.1 dlci 301(0x12D,0x48D0), dynamic,
              broadcast,, status defined, active
Serial0/0 (up): ip 192.168.123.2 dlci 301(0x12D,0x48D0), static,
              broadcast,
              CISCO, status defined, active
R3#
R3#ping 192.168.123.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.123.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/31/84 ms
R3#

point-to-point sub-interface

設定方法

point-to-pointは文字通り1対1で接続されるinterfaceです。従って、main interfaceのように自動的なDLCIとの紐づけはされません。以下のように”interface-dlci”コマンドを使用して明示的にDLCIを定義する必要があります。

Router(config)# interface <sub-interface> point-to-point
Router(config-if)# encapsulation frame-relay
Router(config-if)# ip address <addr> <mask>
Router(config-if)# no shutdown
Router(config-if)# frame-relay interface-dlci <dlci>

動作確認

以下の環境で動作確認を行います。main interfaceを使用する場合との違いはhighlightされた部分になります。

           192.168.123.0/24
                             +------+
                     ┌------+  R2  |
          s0/0      2│    .2+------+
 +------+.1   1+-----+--+  s0/0
 |  R1  +------+  FRSW | 
 +------+      +-----+--+  s0/0
                    3│    .3+------+
                     └------+  R3  |
                             +------+
             1:102 = 2:201
             1:103 = 3:301
 [R1]
interface Serial0/0
 ip address 192.168.123.1 255.255.255.0
 encapsulation frame-relay

 [R2]
interface Serial0/0
 no ip address
 encapsulation frame-relay
!
interface Serial0/0.1 point-to-point
 ip address 192.168.123.2 255.255.255.0
 frame-relay interface-dlci 201

 [R3]
interface Serial0/0
 no ip address
 encapsulation frame-relay
!
interface Serial0/0.1 point-to-point
 ip address 192.168.123.3 255.255.255.0
 frame-relay interface-dlci 301

動作確認

R1, E2, R3間で互いに疎通可能である事を確認します。

R2#ping 192.168.123.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.123.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 24/64/128 ms
R2#
R2#
R2#ping 192.168.123.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.123.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 60/96/224 ms
R2#

multipoint sub-interface

設定方法

multipointは1対多で接続されるinterfaceです。main interfaceと同様にDLCIとの紐づけとinverse arpにより設定する事もできますし、staticに定義する事もできます。

ただしmain interfaceと異なり、inverse arp requestが送信されるのは”interface-dlci”コマンドにより定義されたDLCIのみです

Router(config)# interface <sub-interface> multipoint
Router(config-if)# encapsulation frame-relay
Router(config-if)# ip address <addr> <mask>
Router(config-if)# no shutdown
Router(config-if)# frame-relay interface-dlci <dlci>

動作確認

以下の環境で動作確認を行います。
main interfaceを使用する場合との違いはhighlightされた部分になります。

           192.168.123.0/24
                             +------+
                     ┌------+  R2  |
          s0/0      2│    .2+------+
 +------+.1   1+-----+--+  s0/0
 |  R1  +------+  FRSW | 
 +------+      +-----+--+  s0/0
                    3│    .3+------+
                     └------+  R3  |
                             +------+
             1:102 = 2:201
             1:103 = 3:301
 [R1]
interface Serial0/0
 no ip address
 encapsulation frame-relay
!
interface Serial0/0.1 multipoint
 ip address 192.168.123.1 255.255.255.0
 frame-relay interface-dlci 102
 frame-relay interface-dlci 103

 [R2]
interface Serial0/0
 no ip address
 encapsulation frame-relay
!
interface Serial0/0.1 point-to-point
 ip address 192.168.123.2 255.255.255.0
 frame-relay interface-dlci 201

 [R3]
interface Serial0/0
 no ip address
 encapsulation frame-relay
!
interface Serial0/0.1 point-to-point
 ip address 192.168.123.3 255.255.255.0
 frame-relay interface-dlci 301

動作確認

R1, E2, R3間で互いに疎通可能である事を確認します。

R1#show frame-relay map
Serial0/0.1 (up): ip 192.168.123.2 dlci 102(0x66,0x1860), dynamic,
              broadcast,
              CISCO, status defined, active
Serial0/0.1 (up): ip 192.168.123.3 dlci 103(0x67,0x1870), dynamic,
              broadcast,
              CISCO, status defined, active
R1#
R1#
R1#
R1#ping 192.168.123.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.123.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/57/100 ms
R1#
R1#
R1#ping 192.168.123.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.123.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/66/120 ms
R1#
タイトルとURLをコピーしました