NEC IX ログイン操作

スポンサーリンク

NEC IXをコンソールケーブルのみでメンテナンスするのは非効率です。他のルータ機器と同様にtelnet, ssh, WEB GUI(http)による管理が可能です。ここではログイン操作が可能になるまでの操作の流れを説明します。

コマンド一覧

このシナリオで重要なコマンド一覧は以下の通りです。

Router(config)# telnet-server ip enable
Router(config)# ssh-server ip enable
Router(config)# http-server ip enable
Router(config)# pki private-key generate [{ dsa | rsa }]
Router(config)# username <user> password [{ plain | hash }] <passwd> [ administrator | monitor | operator ]
Router(config)# http-server username <user>

仕様説明

ホスト名

話の趣旨から若干それまずが、リモートログインが可能にする前に、ホスト名を設定しましょう。ホスト間違えの事故は被害甚大ですので、後回しにせず、このタイミングでホスト名を設定してしまいましょう。

ホスト名設定コマンドは以下の通りです。

Router(config)# hostname <hostname>

telnet server

以下のコマンドでtelnetサービスを有効にする事ができます。

Router(config)# telnet-server ip enable

ssh server

以下のコマンドでsshサービスを有効にする事ができます。

Router(config)# ssh-server ip enable

sshはサービスを有効にするだけでなく、以下コマンドにより秘密鍵を作成しなければSSHログインする事ができません。

Router(config)# pki private-key generate [{ dsa | rsa }]

http server

以下のコマンドでhttpサービスを有効にする事ができます。telnet, sshと異なり、httpによる管理の場合はユーザ設定を行わなければ一切の操作ができないようになっております。

Router(config)# http-server ip enable

ユーザ作成

以下のコマンドでユーザを作成する事ができます。ユーザを作成すると、telnet, sshログイン時にパスワード認証を求められるようになります。

Router(config)# username <user> password [{ plain | hash }] <passwd> [ administrator | monitor | operator ]

上記usernameコマンドで作成したユーザ全員にhttpによる操作権限が与えられるわけではありません。httpによる操作権限を与えるには、以下のコマンド入力する必要があります。なお、httpによる操作が可能なのはadministratorの権限を持っているユーザのみです。

Router(config)# http-server username <user>

動作確認環境

以下の構成で動作確認を行います。


            ::100    ::254           .254     ::200
 +---------+ .100     .254 +--------+.254      .200 +---------+
 | Host100 +---------------+ IX2215 +---------------+ Host200 |
 +---------+          G1.0 +--------+ G0.0          +---------+
            192.168.0.0/24           150.0.0.0/24
            2001::/64                2001:150::/64
 [IX2215]
interface GigaEthernet1.0
  ip address 192.168.0.254/24
  ipv6 address 2001::254/64
  no shutdown
!
interface GigaEthernet0.0
  ip address 150.0.0.254/24
  ipv6 address 2001:150::254/64
  no shutdown

初期設定の全文は以下を参照下さい。

IX2215
! NEC Portable Internetwork Core Operating System Software
! IX Series IX2215 (magellan-sec) Software, Version 8.8.22, RELEASE SOFTWARE
! Compiled Jul 04-Wed-2012 13:57:25 JST #2
! Last updated Jan 26-Sun-2014 14:08:48 JST
!
!
timezone +09 00
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
device GigaEthernet0
!
device GigaEthernet1
!
device GigaEthernet2
!
device BRI0
  isdn switch-type hsd128k
!
device USB0
  shutdown
!
interface GigaEthernet0.0
  ip address 150.0.0.254/24
  ipv6 address 2001:150::254/64
  no shutdown
!
interface GigaEthernet1.0
  ip address 192.168.0.254/24
  ipv6 address 2001::254/64
  no shutdown
!
interface GigaEthernet2.0
  no ip address
  shutdown
!
interface BRI0.0
  encapsulation ppp
  no auto-connect
  no ip address
  shutdown
!
interface USB-Serial0.0
  encapsulation ppp
  no auto-connect
  no ip address
  shutdown
!
interface Loopback0.0
  no ip address
!
interface Null0.0
  no ip address

ホスト名設定

リモートログイン可能な状態にする前にホスト名を設定しましょう。ホスト間違えの事故は被害甚大ですので、後回しにせず、このタイミングでホスト名を設定してしまいましょう。

Router(config)# hostname R254
R254(config)#

telnet 接続

telnetサーバの起動

以下のコマンドを投入するとtelnet接続が可能になります。

telnet-server ip enable

ユーザの作成

ユーザ認証なしでログインさせてしまうのは、管理上このましくないので以下コマンドでユーザを作成します。

username cisco password plain cisco

疎通確認

お好みのターミナルソフトでtelnetログイン可能である事を確認します。また、ユーザ認証を求められる事を確認します。

NEC IX telnet接続の操作1

NEC IX telnet接続の操作2

ssh 接続

sshサーバの起動

以下のコマンドを投入するとssh接続が可能になります。

ssh-server ip enable

秘密鍵の作成

以下のコマンドで秘密鍵を作成します。秘密鍵を作成しないと、ルータにsshログインする事ができません。

pki private-key generate rsa

ユーザの作成

ユーザ認証なしでログインさせてしまうのは、管理上このましくないので以下コマンドでユーザを作成します。作成方法は、telnetで使用するユーザと全く同じです。

username cisco password plain cisco

疎通確認

お好みのターミナルソフトでsshログイン可能である事を確認します。また、ユーザ認証を求められる事を確認します。

NEC IX SSH接続の操作1

NEC IX SSH接続の操作2

NEC IX SSH接続の操作3

http 接続

httpサーバの起動

以下のコマンドを投入するとhttp接続が可能になります。

http-server ip enable

疎通確認 認証なし

ブラウザを用いてhttpアクセスをします。この動作確認環境の場合は、”http://192.168.0.254″となります。

NEC IX ブラウザ接続操作1

ユーザの作成

以下のコマンドでユーザを作成し、どのユーザに対してHTTPアクセスを許すのかを定義します。

username http_root password plain http_password administrator
http-server username http_root

疎通確認 認証あり

ブラウザを用いてhttpアクセスをします。ユーザ認証を求められる事を確認します。

NEC IX ブラウザ接続操作2

NEC IX ブラウザ接続操作1

“既にログイン中のユーザがいます”と警告が表示される事があります。“強制ログイン実行”は”svintr-config”に相当する操作でログイン中のユーザを追い出す事を意味します。充分注意して実行して下さい。

NEC IX ブラウザ接続操作4

NEC IX ブラウザ接続操作5

タイトルとURLをコピーしました