NEC IX NTP 設定

スポンサーリンク

NEC IX ルータにおけるNTP設定についてまとめます。多くのルータはインターネット上のNTPサーバと同期するNTP Clientの機能とPCなどの端末に時刻を提供するNTP Serverの機能を備えます。 PCやサーバなどの端末すべてがインターネット上のNTPサーバと同期するのは、ネットワーク機器の負担増につながります。そこで、ある程度の規模になればプライベートネットワーク内にNTPサーバを構築する必要があります。

コマンド一覧

このシナリオで重要なコマンド一覧は以下の通りです。

Router(config)# ntp server <ntp_server> [ priority <num> ]
Router(config)# ntp ip enable
Router(config)# ntp ipv6 enable
Router(config)# ntp master [ <stratum> ]

仕様説明

NTP Client

以下のコマンドで外部のNTPサーバと同期する事ができます。同期対象は名前ではなくIPアドレスで指定してください。また、複数のNTPサーバを指定する事によって外部NTPサーバの障害に備える事ができます。

Router(config)# ntp server <ntp_server> [ priority <num> ]

NTP Server

IXルータはNTPサーバとして機能させる事もできます。全てのクライアント端末がインターネットに時刻の問い合わせを行うのは、ネットワーク機器の負担が大きくなる構成になりますので、ある程度の規模になりました内部ネットワークにNTPサーバを構築する事を検討しましょう。

IXルータをNTPサーバとして機能させるには、”ntp ip enable”, “ntp ipv6 enable”でNTPサーバを有効にします。

Router(config)# ntp ip enable
Router(config)# ntp ipv6 enable

必須設定とは言い切れませんが、以下のコマンドでStratumを変更できます。このコマンドがないと外部NTPサーバよりもStratumが1つ小さい値になってしまいます。プライベートネットワーク内のNTPサーバはStratumが8以上にしておく事をお勧めします。

Router(config)# ntp master [ <stratum> ]

動作確認環境

以下の構成で動作確認を行います。

NEC IX ntpdの動作確認構成

 [R1:Cisco]
router ospf 1
 network 10.1.1.1 0.0.0.0 area 0
 network 192.168.0.1 0.0.0.0 area 0

 [R2:Cisco]
router ospf 1
 network 10.2.2.2 0.0.0.0 area 0
 network 192.168.0.2 0.0.0.0 area 0

 [R254:IX2215]
interface GigaEthernet0.0
 ip address dhcp receive-default
!
ip router ospf 1
  redistribute static metric-type 1
  network 192.168.0.0/24 area 0

初期設定の全文は以下を参照下さい。

R1 config (Cisco 3640)
!

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
ip tcp synwait-time 5
!
!
!
interface Loopback0
 ip address 10.1.1.1 255.255.255.255
!
interface Ethernet0/0
 ip address 192.168.0.1 255.255.255.0
 half-duplex
!
!
router ospf 1
 log-adjacency-changes
 network 10.1.1.1 0.0.0.0 area 0
 network 192.168.0.1 0.0.0.0 area 0
!
no ip http server
ip forward-protocol nd
!
!
!
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end
R2 config (Cisco 3640)
!

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
ip tcp synwait-time 5
!
!
!
interface Loopback0
 ip address 10.2.2.2 255.255.255.255
!
interface Ethernet0/0
 ip address 192.168.0.2 255.255.255.0
 half-duplex
!
!
router ospf 1
 log-adjacency-changes
 network 10.2.2.2 0.0.0.0 area 0
 network 192.168.0.2 0.0.0.0 area 0
!
no ip http server
ip forward-protocol nd
!
!
!
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end
R254 config (IX2215)
Using 1081 out of 1048576 bytes

! NEC Portable Internetwork Core Operating System Software
! IX Series IX2215 (magellan-sec) Software, Version 8.8.22, RELEASE SOFTWARE
! Compiled Jul 04-Wed-2012 13:57:25 JST #2
! Last updated Feb 03-Mon-2014 09:24:27 JST
!
!
hostname R254
timezone +09 00
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
ip router ospf 1
  redistribute static metric-type 1
  area 0
  network 192.168.0.0/24 area 0
!
device GigaEthernet0
!
device GigaEthernet1
!
device GigaEthernet2
!
device BRI0
  isdn switch-type hsd128k
!
device USB0
  shutdown
!
interface GigaEthernet0.0
  ip address dhcp receive-default
  no shutdown
!
interface GigaEthernet1.0
  ip address 192.168.0.254/24
  no shutdown
!
interface GigaEthernet2.0
  no ip address
  shutdown
!
interface BRI0.0
  encapsulation ppp
  no auto-connect
  no ip address
  shutdown
!
interface USB-Serial0.0
  encapsulation ppp
  no auto-connect
  no ip address
  shutdown
!
interface Loopback0.0
  no ip address
!
interface Null0.0
  no ip address

NTP Client

外部NTPサーバとの同期設定

IXルータに外部のNTPサーバとの同期をする設定を投入します。

 [R254:IX2215]
ntp server 133.243.238.163 priority 10
ntp server 133.243.238.164

外部NTPサーバとの同期確認

IXルータが外部のNTPサーバと同期している事を確かめるために、”show ntp”コマンドを入力します。”Clock is synchronized”と表示されている事を確認します。

 [R254:IX2215]
R254(config)# show ntp
NTP status:
  Clock is synchronized, reference is 133.243.238.163
    Rcvd: 0 requests, 5 responses
    Sent: 5 requests, 0 responses
  NTP server                                   St  Ver   Timeout   Last Receive
  133.243.238.163                               1    3        64       9:31:29
  133.243.238.164                               0    0        64       0:00:00
R254(config)#

念のため、時刻が大幅にずれていない事も目視確認しておきましょう。

 [R254:IX2215]
R254(config)# show clock
Monday, 3 February 2014 09:27:49 +09 00
R254(config)#

NTP Server

NTPサーバ設定投入

IXルータをNTPサーバとして動作させるために、NTPを有効にします。

 [R254:IX2215]
ntp ip enable

NTPサーバ設定確認

NEC IXルータをNTPサーバとして動作させ、GNS3上のCiscoルータをIXルータと時刻同期させます。時刻同期の設定は以下の通りです。

 [R1, R2 : Cisco3640]
ntp server 192.168.0.254

CiscoルータがNEC IXルータと時刻同期している事を確認します。”*”マークが時刻同期している事を表します。

 [R1:Cisco3640]
R1#show ntp associations

      address         ref clock     st  when  poll reach  delay  offset    disp
*~192.168.0.254    133.243.238.163   2     6    64  377     8.3   -2.23     3.8
 * master (synced), # master (unsynced), + selected, - candidate, ~ configured
R1#
R1#show ntp associations detail
192.168.0.254 configured, our_master, sane, valid, stratum 2
ref ID 133.243.238.163, time D69966DA.E9428B24 (00:52:42.911 UTC Mon Feb 3 2014)
our mode client, peer mode server, our poll intvl 64, peer poll intvl 64
root delay 0.00 msec, root disp 0.00, reach 377, sync dist 7.950
delay 8.27 msec, offset -2.2313 msec, dispersion 3.81
precision 2**20, version 3
org time D6996710.1260660B (00:53:36.071 UTC Mon Feb 3 2014)
rcv time D6996710.1587668F (00:53:36.084 UTC Mon Feb 3 2014)
xmt time D6996710.106C884A (00:53:36.064 UTC Mon Feb 3 2014)
filtdelay =    19.93   20.16   19.99   19.93   15.98    9.89    8.27   12.18
filtoffset =   -2.35   -0.42    2.36    2.19    4.27   -2.86   -2.23   -4.22
filterror =     0.02    0.99    1.97    1.98    2.00    2.01    2.03    2.04
タイトルとURLをコピーしました