NEC IX PPPoE 設定方法

スポンサーリンク

NEC IX ルータにおけるPPPoEの設定例を紹介します。PPPoEはethernet越しにPPP接続をする事ができる仕様で、この接続形態をとる事によってCHAPによる認証機構を設ける事ができます。インターネットへ接続する際に使用する事が多いプロトコルです。

コマンド一覧

このシナリオで重要なコマンド一覧は以下の通りです。

Router(config)# ppp profile <profile>
Router(config-ppp-<profile>)# authentication myname <local_chap_hostname>
Router(config-ppp-<profile>)# authentication password <remote_chap_hostname> <chap_password&gtl;

Router(config)# interface GigaEthernet0.1
Router(config-GigaEthernet0.1)# ppp binding <profile>
Router(config-GigaEthernet0.1)# ip address ipcp
Router(config-GigaEthernet0.1)# ip address dhcp receive-default

仕様説明

CHAP認証の定義

以下のコマンドでPPP接続に関するパラメータを定義する事ができます。多くの場合は、以下のようなコマンドでCHAPホスト名とCHAPパスワードを定義する事が多いと思います。なお、CHAPホスト名は、資料によってはCHAPユーザ名と表記される事もあります。

Router(config)# ppp profile <profile>
Router(config-ppp-<profile>)# authentication myname <local_chap_hostname>
Router(config-ppp-<profile>)# authentication password <remote_chap_hostname> <chap_password&gtl;

“ppp profile”コマンドで定義したCHAPに関するパラメータは”ppp binging”コマンドで設定を適用します。なお、設定の適用先はメインインターフェースではなく、サブインターフェースである事に注意して下さい。すなわち、サブインターフェース番号は0ではなく1等を使用して下さい。GigaEthernet0.1に対してPPPoE設定を適用して下さい。

Router(config)# interface GigaEthernet0.1
Router(config-GigaEthernet0.1)# ppp binding <profile>

IPアドレスの動的割当

PPPoEを使用する際は、インターネット事業者から動的にIPアドレスを割り当てられる事が多いと思います。以下のようなコマンドでIPCPやDHCPによってIPアドレスを割り当てる事ができます。IPCP(Internet Protocol Control Protocol)とは、PPP接続する際にPPPサーバから動的にIPアドレスを受け取るプロトコルです。

Router(config)# interface GigaEthernet0.1
Router(config-GigaEthernet0.1)# ip address ipcp
Router(config-GigaEthernet0.1)# ip address dhcp receive-default

動作確認環境

以下の構成で動作確認を行います。R1はNEC IX2215で、R2はCisco3640であるベンダー混在環境にて動作確認を行います。

NEC IX PPPoEの動作確認構成

 [R1:IX2215]
hostname R1

 [R2:Cisco3640]
ip address-pool local
!
username CHAP_USER password 0 CHAP_PASSWORD
bba-group pppoe BBA
 virtual-template 1
!
interface Loopback0
 ip address 10.2.2.2 255.255.255.255
!
interface Ethernet0/0
 no ip address
 pppoe enable group BBA
!
interface Virtual-Template1
 ip address 192.168.12.2 255.255.255.0
 no peer neighbor-route
 peer default ip address pool R1
 ppp authentication chap
!
ip local pool R1 192.168.12.1

初期設定の全文は以下を参照下さい。

R1 config (IX2215)
! NEC Portable Internetwork Core Operating System Software
! IX Series IX2215 (magellan-sec) Software, Version 8.8.22, RELEASE SOFTWARE
! Compiled Jul 04-Wed-2012 13:57:25 JST #2
! Current time Feb 11-Tue-2014 21:41:14 JST
!
!
hostname R1
timezone +09 00
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
device GigaEthernet0
!
device GigaEthernet1
!
device GigaEthernet2
!
device BRI0
  isdn switch-type hsd128k
!
device USB0
  shutdown
!
interface GigaEthernet0.0
  no ip address
  shutdown
!
interface GigaEthernet1.0
  no ip address
  shutdown
!
interface GigaEthernet2.0
  no ip address
  shutdown
!
interface BRI0.0
  encapsulation ppp
  no auto-connect
  no ip address
  shutdown
!
interface USB-Serial0.0
  encapsulation ppp
  no auto-connect
  no ip address
  shutdown
!
interface Loopback0.0
  no ip address
!
interface Null0.0
  no ip address
R2 config (Cisco 3640)
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
!
!
ip cef
no ip domain lookup
!
!
ip address-pool local
!
!
!
!
!
!
!
!
!
!
!
!
username CHAP_USER password 0 CHAP_PASSWORD
!
!
ip tcp synwait-time 5
!
!
bba-group pppoe BBA
 virtual-template 1
!
!
interface Loopback0
 ip address 10.2.2.2 255.255.255.255
!
interface Ethernet0/0
 no ip address
 half-duplex
 pppoe enable group BBA
!
interface Virtual-Template1
 ip address 192.168.12.2 255.255.255.0
 no peer neighbor-route
 peer default ip address pool R1
 ppp authentication chap
!
!
ip local pool R1 192.168.12.1
no ip http server
ip forward-protocol nd
!
!
!
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

PPPoE 設定例

PPPoE 設定

以下のコマンドでCHAPホスト名とパスワードを定義します。なお、不要なトラブルを避けるために、R1, R2で同一のCHAPホスト名を指定しております。

 [R1:IX2215]
ppp profile r2
 authentication myname CHAP_USER
 authentication password CHAP_USER CHAP_PASSWORD
!
interface GigaEthernet0.1
 ppp binding r2
 no shutdown

IPCPによってIPアドレスを取得するように設定します。

 [R1:IX2215]
interface GigaEthernet0.1
 ip address ipcp

PPPoE 動作確認

“show ip interface”の出力を確認します。up状態である事と、IPCPによってIPアドレスを取得できている事を確認します。

 [R1:IX2215]
R1# show ip interface GigaEthernet0.1
Interface GigaEthernet0.1 is up, line protocol is up
  Internet address is 192.168.12.1/32
  Broadcast address is 255.255.255.255
  Peer address is 192.168.12.2
  Address determined by IPCP
  MTU is 1492 octets
  Directed broadcast forwarding is disabled
  Proxy ARP is disabled
  Local proxy ARP is disabled
  ICMP redirects are never sent
  IGMP is disabled
  TCP MSS adjustment size is 1452
R1#
タイトルとURLをコピーしました